1

I'm running Ubuntu 18.04 with GNOME. When I hit Super+1, the first program in my left favorites bar, aka Ubuntu Dock (in my case, Firefox) starts up. If I hit Super+1 again, it switches to the existing Firefox instance. I would like it to start a new Firefox process instead.

I followed the instructions in this question, which works if I go into the launcher by hand, but it doesn't work for the keyboard shortcuts Super+1, etc. Also, it seems that Super+1 is not listed as a keyboard shortcut in the settings, so I can't simply override the binding myself. How can I get a new process to start when I hit Super+Number, for Number from 1 to 9?

2
2

This behaviour is controlled by the Ubuntu Dock gnome extension. It uses the same backend as the very popular Gnome Shell extension "Dash to Dock". There is no option to change the behaviour of the Super+Number keys. You can resort to a perhaps less perfect workaround.

Workaround: Disable that functionality of the dock. Then, use "Keyboard" - "Settings" to manually assign the Super+Number for launching applications according to how they are pinned on the launcher. For instance, assign the Super+1 hotkey to launch Firefox.

To disable the Super+Number functionality of the Dock, open a terminal and issue following command:

gsettings set org.gnome.shell.extensions.dash-to-dock hot-keys false

If you change your mind, you can restore the default behaviour with the command:

gsettings reset org.gnome.shell.extensions.dash-to-dock hot-keys

In practice, this will work very well for your pinned applications. However, the hotkeys will not automatically be updated if you change the order of your favourites. Also, you cannot have corresponding Super+Number keys for icons that are not pinned as favourites, because these icons change all the time.

1
  • This is exactly what I was looking for. In practice, I only use these shortcuts for ~3 applications, so assigning them by hand works perfectly. Thank you! – Silvio Mayolo Jul 22 '19 at 19:58
0

Ubuntu 19.04 or Newer

I'm just posting a secondary answer in case someone finds this question later. The solution suggested by vanadium is sufficient on Ubuntu 18.04. If you're running 19.04 or 20.04, in addition to his answer, you also have to change

gsettings set org.gnome.shell.extensions.dash-to-dock app-hotkey-1 '[]'
gsettings set org.gnome.shell.keybindings switch-to-application-1 '[]'

and do so for each keybinding you want to override (i.e. by changing the 1 to be the requisite digit). See this question for more details.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.