1

I've set up a dual boot of Ubuntu 19.04 with Windows 10. Soon I started getting stuck on a purple screen when I booted up with Ubuntu.

Changed GRUB_LINUX_DEFAULT="quiet splash" to "GRUB_LINUX_DEFAULT="nomodeset" following online tutorials.

Now I just get stuck at

hdaudio hdaudio C0D3: unable to bind the codec

Why is that not letting me boot up at all?

1
1

What worked for me was removing nomodeset.

Context being - after removing nomodeset, I could get past the hdaudio hdaudio C0D3: unable to bind the codec error onto the login screen and could log in, but my HP laptop would shut down abruptly - which is why I had nomodeset in the first place.

My NVIDIA drivers were messy. They wouldn't function, nor would they get installed properly.

After some forum reading, it turned out that nomodeset isn't a necessity if nvidia drivers are installed properly. I installed a fresh copy of Ubuntu 20.04 LTS, booted in while keeping nomodeset, apt installed nvidia-utils-470, rebooted. Now, NVIDIA drivers don't let your PC boot with nomodeset. Rebooted into a root shell in recovery mode, verified NVIDIA drivers are working with nvidia-smi. Removed nomodeset from grub, and rebooted.

Everything was working fine now. Could install Display Link drivers and could reboot without any errors.

0

Well this did it. All I had to do was remove "nomodeset", which was supposed to be the solution.

Ubuntu 19.04 Freeze at loading DELL E6430 i5 - nomodeset didn't work well

2
  • Same problem on my Surface Laptop 3 13.5 inch, I removed "nosplash" and that didn't change anything
    – xjcl
    Feb 3 '20 at 19:43
  • If your answer is essentially a referral to another question, it would be better to flag this question as a duplicate of the other once you earned 15 reputation. If you have the reputation, don't forget to vote for the answer(s) there that you found useful!
    – Melebius
    Feb 4 '20 at 12:11
0

Friends,

Thank you for mentioning 'NVIDIA drivers'.

After checked on terminal (Ctrl+Alt+F2) the sudo apt update, I observed an error and removed the dpkg nvidia-340, using the kindly guidance on this website: https://phoenixnap.com/kb/fix-sub-process-usr-bin-dpkg-returned-error-code-1

After that, the OS boot happened (the blinking cursor screen "disappeared"), going to login page.

All done, I changed "GRUB_LINUX_DEFAULT="nomodeset noresume" to "GRUB_LINUX_DEFAULT="quiet splash"" back due to OS performance by pressing "shift during boot, then hit 'e' to edit the GRUB entry, and finding the "nomodeset noresume" (without "") in one of the last command lines.

With the desire to do good to you (love).

2
  • 1
    While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review Oct 22 at 18:34
  • And please remove the "fluffy" language. I recognize your good intentions but an answer is more useful without your first and last lines. Oct 22 at 19:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.