I am trying to install Lubuntu 19.04 on a new Lenovo Ideapad 130S-11IGM, but when I get to the partition page, the option "Erase disk" does not appear. The current OS is Windows 10, which I have no interest in keeping. How can I get the option to erase everything?

SecureBoot is disabled in BIOS. I was not able to find a Fastboot setting in BIOS. Thanks.

Update 1: I have run "check disk for errors" and no errors were found.

Update 2: The problem is solved by taking the only option available (manual partitions) and setting up the partitions according to the instructions at the bottom of the document linked by guiverc in the comments below. Briefly, because this machine has UEFI booting, it is necessary to make a small partition for that boot system in addition to the main partition. Follow these steps: "New partition table" (I chose MBR). Then "Free space"->"Create"-> make a FAT32 partition with EPS flag set, with mount point /boot/efi/. 260 MiB worked for me. Next do "Free space"->"Create"-> make a partition using the remaining available space, with mount point /. Several filesystems are possible, I chose ext4. At this point the "Next" button becomes clickable and everything else is straightforward. ALL DATA WILL BE LOST BY THIS PROCEDURE. Only do this if you want to erase everything.

In case anyone else has the same machine with the Realtek 8821CE wifi, next you are going to need to install the driver. The instructions here worked for me: How to install Wi-Fi driver for Realtek RTL8821CE on Ubuntu 18.04?

Lubuntu installer screenshot with manual partitioning option only

  • 1
    I don't know your issue or your fix, however in your place I'd ensure you'd run the check disc for defects option to ensure you download & media were perfect (there is mention of it in the manual manual.lubuntu.me/1/1.3/installation.html), then I'd explore manual-partition options to see what's there and if any errors occur with deleting partitions (given that's what you're going to do) & re-creating as you'll end up with. I'd hope the 'erase disk' option just appears then.
    – guiverc
    Jul 22, 2019 at 12:26
  • @guiverc Thanks for the idea, I just checked disk for defects and none were found. Exploring the manual-partitions option with randomly clicking around, I could not get the "Next" button to become clickable. I am hoping for a solution where I don't have to research proper setup of manual partitions, but that will be the next step if necessary. Jul 22, 2019 at 12:42
  • 1
    Manual partitioning is covered late on the aforementioned reference manual page, I recall a sony vaio that I found annoying to install on, and by deleting partitions it eventually became easy (and I could just click erase disk & install which is what I was hoping would occur for you). The next button you mention will allow clicking when it's got a workable solution available (ie. a / partition it can install to)
    – guiverc
    Jul 22, 2019 at 12:54
  • I was able to follow the instructions on the end of the page you mentioned and come up with an acceptable partition. The option to "erase & install" never appeared, but installation was successful, so no complaints in the end. Thanks! Jul 22, 2019 at 18:13

2 Answers 2


As suggested in the Lubuntu manual, the installer will not give you the "erase disk" option if you have anything on the target device mounted:

If you have had a previous linux install and want to put the entire disk or just replace an entire partition you will need to unmount them.

The most likely cause for this is that swaps have been automounted. This is a "feature" of the Ubuntu ecosystem to provide as much memory for the live system as possible. Here, too, the manual provides the solution:

In this case running

sudo swapoff -a

will unmount them and any partitions with data mounted can be unmounted through pcmanfm-qt.

I have also seen a few cases where partitions on eMMC devices (which is what your target is) seem to be automounted, though not having the hardware myself, I cannot confirm this.

There is an upstream bug to provide some other solution to this issue.

  • I just completed the installation by following a guide linked by guiverc in the comments above, so I cannot try this solution but hope that it does help for someone. (I had previously Windows 10 and not linux, but perhaps it does not matter for the swaps.) Jul 22, 2019 at 18:16
  • 1
    @LindaBrownWestrick I'd vote to accept this solution; it's most probably the exact cause.
    – guiverc
    Jul 22, 2019 at 23:17
  • 1
    All right, accepted that although I was not able to test it myself. Assuming it would work regardless of prior operating system, the manual writers could have started that note with "if erase disk does not appear..." rather than "if you had a previous linux install..." I skimmed right over it several times believing it had no relevance to my situation. Jul 24, 2019 at 11:52

I had the same problem when trying to install Lubuntu 20.04 LTS:


I solved it by opening PCManFM (my file manager) and unmounting my eMMC drive and then starting the installation procedure again. I then got all the four options that i'm used to:

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .