2

I am posting here with a quick question. I have been using Ubuntu 18.04 for sometime now. I love it but i have one little thing that bugs the heck out of me. The WIFI works fine and even the WiFi button works to turn the connection on and off. Only thing that does not work is the color changing light. It stays orange when it should change to a white light when it is working. Does anyone know if there is a way to fix this?

Thanks

2
  • you tried it on another OS? Jul 22, 2019 at 9:23
  • Yes works in windows just fine. Jul 22, 2019 at 15:52

1 Answer 1

0

I have solved this by playing around in the BIOS. I believe disabling and reenabling Wireless Button State did the trick for me.

Differences:

  • I am using Arch, not Ubuntu.
  • The LED remained white, not orange.
  • I am not sure which generation I am using but I believe it's an older one.

More Details:

I was able to bind the button e.g. in i3/sway config with

bindsym XF86RFKill                  exec --no-startup-id rfkill block all

As pointed out in this question the desired status of the LED was correctly reflected by

cat /sys/class/leds/phy0-led/brightness

When wifi was on (can be checked with rfkill) it printed 1 when wifi was off it printed 0. The real LED, however, did not care about that. It always stayed white while the computer was running.

When booting up and powering down the color of the LED changed so I knew that this was not a hardware defect.

The kernel option CONFIG_HP_WIRELESS is set to m:

$ zcat /proc/config.gz | grep HP_WIRELESS
CONFIG_HP_WIRELESS=m

The module is loaded:

$ lsmod | grep hp_wireless
hp_wireless            16384  0

I am using the driver iwlwifi:

$ lspci -nnk | grep -iA5 network
03:00.0 Network controller [0280]: Intel Corporation Wireless 7265 [8086:095a] (rev 48)
    DeviceName: WLAN
    Subsystem: Intel Corporation Dual Band Wireless-AC 7265 [8086:5010]
    Kernel driver in use: iwlwifi
    Kernel modules: iwlwifi

Solution:

Open the BIOS Setup. When powering on the laptop it displays the text "Press the Esc key for Startup Menu" in the lower left corner while displaying the hp logo in the center of the screen. Press the Esc key until the color of the text is inverted. Select BIOS Setup with the arrow keys and press enter.

Go to the option Advanced > Built-In Device Options > Wireless Button State. It was enabled. I disabled it and booted up. The wifi button was not working anymore. I enabled the option in the BIOS again, booted up again and the button works: When pressing it it toggles and the LED displays the correct status of the WIFI. Even when disabling/enabling WIFI with nmcli r wifi on/off instead of the hardware button the color of the LED changes as desired.

(I have also changed other BIOS settings in the same go like disabling WWAN and enabling wake on lid open so it's difficult to say for sure that it was this very option which made the difference but it's the only one which sounds plausible.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.