2

Why is my Ubuntu Mate 16.04 runs hotter than my Windows 7 on my Core2 Penryn P8700 and ATI Mobility Radeon HD 3670 laptop?

I ran lm-sensors and found that the GPU temp consistently hits 63 and 64 C, while on Windows 7 is only about 47-49 C with openhardwaremonitor.

I have tried it on both Ubuntu Mate 16.04.06 and newer Kali 2019.01, both OSes hit almost very similar temperature at 63 / 64 C on just running the terminal with lm-sensors. Even in Kali before I started X by running $ startx, the temp already hit 63 C just after login in Kali. Windows 7 is just about 46-47 C while started and still way cooler.

I ran both OS while nothing is opened-- just terminal on Linux with lm-sensors and openhardwardmonitor on Windows.

I started using Linux in 2011 using Ubuntu 10.04 and 10.10 with Gnome 2.xx. It ran so light and cool. And stable indeed. Almost switched to it completely. Then Gnome 3 came out with Ubuntu 12.04 and later. Switched back to Windows 7, bcoz Ubuntu with Gnome 3 was lamer & ((uglier)) (imo) and crashes as often as Windows if not more (my Gnome 3 experience with 12.04). Ubuntu Mate 16.04 also still crashes more than even 10.10 (in Core2 still). Idk why and curious to find out as to why the degradation of quality with the open sourced Linux distros.

I have read somewhere, that the open sourced Linux graphic drivers is not as good as the proprietary AMD drivers: http://www.cgl.ucsf.edu/chimera/graphics/updatelinux.html and that the Linux drivers can't adjust the clock (I read somewhere, but lost the site reference as of now).

Haven't tried other distros like Arch, I am mostly just familiar with just Debian distros.

Can anyone help explain? And what should I do, how can I improve the performance and thermal efficiency of my GPU on my system using Linux? (Preferably software/OS wise, not recommendation to clean and reapply thermal paste on my laptop-- I vacuum my laptop quite regularly indeed, so it's pretty clean and dustless ;)

I have also tried to install the AMD proprietary drivers recently here: The program 'gcc' is not currently installed. Trying to install AMD Catalyst Driver on Ubuntu Mate 16.04? but still no success.

  • The proprietary AMD drivers will not work with hardware that old. So you'll have to use the open-source ones, which still work fine (normally). One thing you can try is to disable desktop effects - IIRC it's in "Mate Tweak" or something like that, somewhere in the settings. you can do this by changing the compositor, either to "none" or to "compton", especially if it's set to Compiz, since compiz uses a lot of GPU for providing animations (especially stuff like wobbly windows and desktop cube, uses more GPU if you turn them on) – JonasCz - Reinstate Monica Jul 21 '19 at 19:47
  • I also tested on Kali Mate 2019.01 just after login, before starting X, and it also shows 63 C. Yeah other dude also said that AMD driver wont work on 16.04 thou (from my other question). Not sure if your modification will have any effect, but we'll see after I cooled down and restart. – K4ll-of-D00ty Jul 21 '19 at 19:54
  • If it gets hot without stating X, then probably not. In which case I'm out of ideas.. – JonasCz - Reinstate Monica Jul 21 '19 at 19:57
  • @K4ll-of-D00ty As your hardware is from 2008 then I can recommend to try Ubuntu MATE 14.04.2 LTS which has proprietary fglrx driver inside. This will give you an estimation of the possible powersaving by means of proprietary driver. Install it with sudo apt-get install fglrx-amdcccle, reboot and check settings from amdcccle. – N0rbert Jul 21 '19 at 20:49
1

If your main concern is CPU/GPU heat control, you can install TLP:

sudo apt install tlp tlp-rdw

After installation run sudo tlp start and reboot.

TLP provides AMD Radeon GPU power management (KMS and DPM), this is probably what you need.

You will see reduced heating after installation and reboot. However, it may take a few days to get the full effect of TLP.

TLP provides power management and longer battery life as well.

Please read more about TLP here.

|improve this answer|||||
  • 1
    Ok, will try tomorrow. Gonna sleep now.. thx – K4ll-of-D00ty Jul 21 '19 at 20:02
1

After almost 6 months since I asked, I finally found the answers.

I simply googled 'fglrx'. From there to : https://help.ubuntu.com/community/BinaryDriverHowto/AMD. Don't install the fglrx or any AMD proprietary driver. As the AMD proprietary drivers is only supported up to Linux kernel 3.4 (Go look it up at official AMD's driver download website.)

Go back up one-level to : https://help.ubuntu.com/community/BinaryDriverHowto/. Look it up and determine which driver you need / can use.

In my case, I found the fix inside the open source RadeonDriver link there : https://help.ubuntu.com/community/RadeonDriver, the simple fix is in the 'Power Management' section.

It says:

For the most recent ATI/AMD graphic cards supported by the Radeon driver, DPM (Dynamic Power Management) should work automatically without additional steps.

Instead if you notice overheating problems and/or you have an old Radeon HD graphic card, you can enable DPM by adding a boot parameter. This should greatly help power consumption, especially when idle. To do so, edit /etc/default/grub and add the 'radeon.dpm=1' to the GRUB_CMDLINE_LINUX_DEFAULT line, so it would look something like: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.dpm=1"

After you save/quit the text editor, update grub: sudo update-grub

It basically activates the Radeon driver DPM (Dynamic Power Management), a feature added in 2013 in the open-sourced Radeon driver (look up 'radeon dpm'), by modifying / adding the kernel boot parameter. The fix was easy enough and works for me. My VGA temp is now about 47-49 C when idle, on par with my idle temp using Windows 7.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.