10

Natural scrolling using ".Xmodmap": pointer = 1 2 3 5 4 7 6 8 9 10 11 12 doesn't work anymore in 12.04 on some Ubuntu-specific apps like the Software Center, settings window, and update-center. Under what package should I report the bug?

3 Answers 3

11

I'm horribly late to this, but I just finished writing a guide which could help you or anyone passing by. If you still have this problem, that is.

The gist of it is that you need to get your touchpad's ID with the xinput list command, then the current scrolling distance with xinput list-props [touchpad-id] | grep "Scrolling distance". The output should be something like:

Synaptics Scrolling Distance (288): 106, 106

Here, 288 is the property ID and 106, 106 are the current values. What you need to do is invert the numbers - here, the new values will be -106, -106. This command does it:

xinput set-prop [touchpad-id] [property-id] [new-values]

I have this in a shell script set to run on login, along with commands to restart nautilus, which may or may not work for you (it's in the linked blog post).

5
  • That's great. It actually fixed the problem for me! Thanks so much! May 28, 2012 at 14:07
  • 1
    Works for me as well. But note that you have to turn of the Natural Scrolling application afterwards. Otherwise the behavior in all windows is just inverted :) Aug 2, 2012 at 6:45
  • @Andy C. is there a way to do the same for my mouse? Aug 6, 2012 at 15:45
  • 1
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – Seth
    Jul 11, 2013 at 17:44
  • Thanks! I used several ways on 15.04 including Ubuntu Tweak's Natural Scrolling and they all only worked for some cases but not all. This finally seems to be a OS version independent solution.
    – schluchc
    Sep 11, 2015 at 17:27
5

I suppose the best way to do this is by using dconf-editor:

  • Open Terminal
  • Type in dconf-editor and hit Enter
  • Now go to org>gnome>settings-daemon>peripherals>touchpad and uncheck natural scroll

You may need to install dconf-editor first, by executing sudo apt-get install dconf-editor in the terminal.

This will only reverse the scroll direction of the touchpad, not of an external mouse.

Here's a screenshot of dconf-editor after making changes:

enter image description here

4
  • Hang on, since when has this existed?
    – Andy C.
    Jul 25, 2013 at 11:24
  • 1
    I have used Ubuntu 12.04+ mainly, and it has been there in each and every version.
    – Ranveer
    Jul 25, 2013 at 17:54
  • 1
    Strange, I use 12.04 with the latest updates and this option is missing.
    – Radu Maris
    Aug 26, 2014 at 11:05
  • If it ain't there, try sudo apt-get install dconf-tools
    – Ranveer
    Aug 26, 2014 at 11:11
1

Bug #949465 is a similar-sounding duplicate which was reported for natural scrolling in Nautilus. It's filed against the libxi package, so you may want to try filing it there.

Either that, or may want to try filing bugs against the packages for all affected windows. For example, the packages for the software you have listed above would be:

  • Ubuntu Software Center: software-center
  • System Settings: gnome-control-center
  • Update Manager: update-manager

You can report bugs against any of these by running ubuntu-bug in a terminal, followed by the name of the desired package.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.