0

The last time I booted my computer I could no longer access the wifi adapter, after some looking around I realized that Ubuntu was not finding any Wifi adapter in the system, it was working fine until I booted my system I'm guessing it was because of one of the internal updates which I get every day. From other posts, I've seen people asking for output of

lspci -knn | grep Net -A3; rfkill list

Which is:

03:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter [10ec:8179] (rev 01) Subsystem: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter [10ec:8197] Kernel modules: rtl8188ee

I have tried a lot of approaches mentioned on various platforms including the questions answered for an almost a duplicate question on askubuntu and none of the approaches solves my problem that is why I needed to ask a new question. There isn't any problem in the Wifi adapter physically because I have Ubuntu dual booted on my desktop and it works fine in Windows. Also, I have connected the computer with an ethernet cable from the wifi router and it works fine as well.

  • 1
    Could you please be more specific about the 'approaches' you've tried so far? For example, which question on AU did you follow to no success? Try plugging in the ethernet cable while the wifi adapter is plugged in, and running the commands listed in this answer – David Jul 21 at 18:40
  • 2
    Does wireless work after sudo modprobe -v rtl8188ee or does it give an error? – Jeremy31 Jul 21 at 19:23
  • sudo modprobe -v rtl8188ee gives the following error. insmod /lib/modules/4.15.0-54-generic/updates/dkms/rtlwifi.ko modprobe: ERROR: could not insert 'rtl8188ee': Unknown symbol in module, or unknown parameter (see dmesg) And this is the answer I followed on AU. link – Akshit Aggarwal Jul 22 at 5:01
  • This problem was resolved once I ran the command sudo apt upgrade there were a lot of upgrades pending worth over 300Mbs which are now done. – Akshit Aggarwal Jul 22 at 13:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.