0

I have an old, 32-bit Dell Inspiron 1505 laptop that had been running an earlier version Lubuntu. I recently installed Lubuntu 18.04 and it initially worked. Then, following a major software update to that re-installation (45 minutes), an unusual boot problem occurred.

Detailed description of issue:

  • Press power button once: Dell splash screen > brief flash of dim background light > Grub menu appears > screen remains black for as long as I let it sit there, but the power indicator light remains ON. So power is on but with a black screen.
  • Press and hold power button: brief flash of dim background light > power goes OFF. Power indicator light OFF. No power to the laptop.
  • Press power button a 2nd time: Dell splash Screen > Grub Menu > blinking cursor > /dev/sda1/ recovering journal, followed by a minute of messages for starting various services and modules > Lubuntu desktop opens. Power light ON, hard drive light OFF, until I open a browser; then the hhd light turns ON.
  • So, I am able to access the GRUB menu on the 2nd power boot and open Lubuntu
  • I can boot from either the USB or DVD options, and from a Live DVD USB or disk

Actions taken so far:

  • I have run 'Boot Repair Disk' twice. I have posted its report at http://paste.ubuntu.com/p/WZdNGXKWzG for further info.
  • If it matters, the battery on this laptop is no longer taking a charge.
  • I have run MemTest+86 and hard drive S.M.A.R.T. tests, and they show no errors
  • sda1 is using the ext4 file format.

I have researched this problem and identified several potential solutions:

  1. Edit Grub file and replace 'quiet splash' with nomodset
  2. Use a different kernel (I only have 1 on the Grub menu)
  3. Disconnect a USB mouse (didn't help)
  4. Substitue gdm for lightdgm as default log in manager (how to do this?)
  5. Boot into a recovery mode and run fsck
  6. Examine the /var/log/dpkg.log for errors
  7. I have read there is a bug with Lubuntu 18.04 on 32-bit systems

So if Grub menu works, power to the laptop is on (on 2nd power button), and hardware is not an issue (hhd and RAM tested good), then at what point does this boot problem occur, what does 'recovering journal' imply, and how do I fix it? It seems to me to be a software, rather than a hardware problem, but any suggestions would be most appreciated to this highly frustrating boot problem. Thanks.

UPDATE: Dell Inspiron 1505

CURRENT BOOT PROCESS:

  1. Power ON > power light ON
  2. Dell splash screen immediately for 5 seconds but no GRUB Menu
  3. Black screen (power light still on; hard drive spinning) remains indefinitely
  4. Power OFF (hard shutdown). Power light off
  5. Power ON: Power light ON > Dell splash screen (5 seconds) > Grub Menu > select Lubuntu > /dev/sda1: recovering journal and clean (30 seconds) > Lubuntu desktop
  6. When reaching Desktop, a different screen resolution appears

ACTIONS SO FAR:

  1. Check var/log/dpkg.log. Nothing obvious
  2. Architecture: uname -m (i686). Processor is Intel T2300 @ 1.66 GHz; 1 processor; 2 cores; 2 threads. (i686 is start of Pentium Pro, Pentium)
  3. Sudo apt update and sudo apt full-upgrade. Completed (this is where the problem is created)`
  4. File System: df - T /dev/sda1 - ext4
  5. Sysrq + Alt: R S E I U O (safe shutdown): NO at 1st power ON but Yes at Desktop, after 2nd power ON.
  6. Edit GRUB: sudo gedit edit/default/grub) remove 'quiet splash' (did not do this)
  7. Sudo Blkid: /dev/sda1 : UUID = 2722594f-278e-41a4-b036-69d69d670451. TYPE ID = ext 4/ PARTUUID = 025f64f6-01
  8. Tried to use alternative Superblocks with fsck, but did not work.

VARIOUS ERROR MESSAGES:

  1. The superblock could not be real or does not describe a valid ext 2-4 file system. File system fsck ext2 not a directory. If device is valid then superblock is corrupted. Try running e2fsck with an alternative superblock: e2f\fsck -b (superblock). Superblocks: 32768-98304-163840-229376-274212-819200-884736-1605632-2654208-4096000- 7962624
  2. Fsck > unable to continue/aborted. Device is mounted
  3. Missing mtab file /etc/fstab and /etc/mtab
  4. Can't check if file system is mounted due to missing mtab file
  5. Can't find device in /etc/fstab
  6. Fdisk -l: Can't open /dev/sda. Permission denied
  7. Sudo fsck -f /dev/sda1 Cannot continue e2fsck because /dev/sda1 is mounted
  8. Cat/proc/sys/kernel/sysrq: No such file or directory
  9. Sudo gedit etc/default/grub. Opened file, with error message "error retrieving accessibility bus address"
  10. Edit SysRq file: /etc/sysctl.d/10-magic-sysrq.conf. Can't open file to write
  11. Umount -l /dev/sda1 > sudo fsck -f /dev/sda1 > Effective uid is not 0. Is /usr/bin/sudo on a file system without 'nosuid' option set or an MFS file system without root privileges?
  12. Edit various system files: "Can't open file to write"

At this point, I am tempted simply to run Lubuntu off a Live USB with persistence. Any suggestions would be appreciated.

2nd Update July 25

I had initially created a Lubuntu bootable USB for Lubuntu 18.04 using "Linux Live USB Creator". When I ran it, it said it only supported certain versions of Lubuntu, the last one being version 15.xx, and would use that to create my 18.04 version. I thought this might be causing the problem. So I created another bootable USB for 18.04, using MKUSB. That produced a bootable USB with more boot options (Persistence, Live, Safe, etc). But it DID NOT solve the original problem.

I ran sudo fsck -l /dev/sda1 from the 2nd USB and it completed w/o errors.

So I have decided to simply Power on/Power off/Power on, to boot from the hard drive, and use the bootable USB as a backup (in case errors/corruptions/feature limitations occur booting from the hhd. Kind of an inconvenient work-around. With that, I have closed this question.

  • did you install the 64 bit version of the 32 bit? lubuntu.net/tags/lubuntu-18-04 – Graham Jul 21 at 13:23
  • Can you remove quiet splash and see what comes up then? (don't do the nomodeset) – Fabby Jul 21 at 13:37
  • Recovering journal means only that you didn't shutdown the system cleanly the prior time (which occurs if you power-off using power-button to force-shutdown power; can you perform a safe shutdown using magic sysrq keys? instead). What is the bug you read about on Lubuntu 18.04 on 32bit (x86) systems? You also mention some strange things, eg. gdm3 (gnome display manager) replaced by lightdm? If you were using lubuntu why would you have gdm3 used by Ubuntu 18.04? Have you sudo apt update to update software lists, then sudo apt full-upgrade to ensure you're fully upgraded? – guiverc Jul 21 at 14:46
  • status please... – heynnema Jul 22 at 16:00
  • status please... – heynnema Jul 24 at 14:48
1

Lets first check your file system for errors.

For 18.04 or newer...

  • boot to a Ubuntu Live DVD/USB
  • open a terminal window by pressing Ctrl+Alt+T
  • type sudo fdisk -l
  • identify the /dev/XXXX device name for your "Linux Filesystem"
  • type sudo fsck -f /dev/XXXX, replacing XXXX with the number you found earlier
  • repeat the fsck command if there were errors
  • type reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.