1

I have an old computer, and I decided to make a server out of it, install Ubuntu 19.04 server on it, and everything was fine until I tried to configure a static interface. I ordered it from the provider. Everything went well, but when I insert it into netplan, when I log in via ssh (I use PuTTY and WinSCP), access is denied. Port 2323 is configured in sshd_config, and when netplan is the default setting, it works, but when there is a static ip, I still need port 22 to connect.

network:
    renderer: networkd
    ethernets:
        enp0s7:
            dhcp4: no
            addresses: [193.186.9.39/24]
            gateway4: 193.186.9.1
            nameservers:
                     addresses: [193.186.9.1,8.8.8.8]

Ufw info:

sudo ufw status verbose

enter image description here

Connection on port 22, 193.186.9.39 (static):

enter image description here

Connection on port 2323 : Network Error: Connection timed out

enter image description here

I tried to give access from the Internet to my sites and programs, but so far I have encountered such a problem. In Ubuntu, I recently. I beg you to help, I have been suffering for 3 days. Thank you very much.


up.

sudo netstat -tnlp | grep ssh enter image description here

ping www.google.com enter image description here

Everything is fine when the netplan

network:
    version: 2
    ethernets:
        enp0s7:
            dhcp4: true

sshd_config

# $OpenBSD: sshd_config,v 1.103 2018/04/09 20:41:22 tj Exp $
# This is the sshd server system-wide configuration file.  See
# sshd_config(5) for more information.
# This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin
# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented.  Uncommented options override the
# default value.

Port 2323
#AddressFamily any
#ListenAddress 0.0.0.0
#ListenAddress ::

HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_ecdsa_key
#HostKey /etc/ssh/ssh_host_ed25519_key

# Ciphers and keying
#RekeyLimit default none

# Logging
#SyslogFacility AUTH
#LogLevel INFO

# Authentication:

#LoginGraceTime 1m
PermitRootLogin no
StrictModes yes
AllowUsers aborigen
#MaxAuthTries 6
#MaxSessions 10

PubkeyAuthentication yes

# Expect .ssh/authorized_keys2 to be disregarded by default in future.
#AuthorizedKeysFile .ssh/authorized_keys .ssh/authorized_keys2

#AuthorizedPrincipalsFile none

#AuthorizedKeysCommand none
#AuthorizedKeysCommandUser nobody

# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
#PasswordAuthentication yes
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
#KerberosGetAFSToken no

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes
#GSSAPIStrictAcceptorCheck yes
#GSSAPIKeyExchange no

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes

#AllowAgentForwarding yes
#AllowTcpForwarding yes
#GatewayPorts no
#X11Forwarding yes
#X11DisplayOffset 10
#X11UseLocalhost yes
#PermitTTY yes
PrintMotd no
#PrintLastLog yes
#TCPKeepAlive yes
#PermitUserEnvironment no
#Compression delayed
#ClientAliveInterval 0
#ClientAliveCountMax 3
#UseDNS no
#PidFile /var/run/sshd.pid
#MaxStartups 10:30:100
#PermitTunnel no
#ChrootDirectory none
#VersionAddendum none

# no default banner path
#Banner none

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

# override default of no subsystems
Subsystem   sftp    /usr/lib/openssh/sftp-server

# Example of overriding settings on a per-user basis
#Match User anoncvs
#   X11Forwarding no
#   AllowTcpForwarding no
#   PermitTTY no
#   ForceCommand cvs server
  • 1
    What's the output of sudo netstat -tnlp | grep ssh? Does the machine have internet connectivity? Can you include sshd_config in your question? – vidarlo Jul 21 at 11:05
  • Does internet work on the machine? What happens if you run ping www.google.com? – vidarlo Jul 22 at 9:53
  • i include images – Andry Kritsun Jul 22 at 10:20
  • Please don't use images for text. But the problem is that you don't have a working internet connection. Are you sure that the settings is correct? What happens if you try ping 8.8.8.8? – vidarlo Jul 22 at 10:21
  • ping 8.8.8.8 response: destination host unreachable – Andry Kritsun Jul 26 at 15:22
0

Setting up port forwarding on the router solved my problem. No need to touch anything in the netplan.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.