2

I have dual booted ubuntu 18.04 with windows 10 but i am facing slow startup on ubuntu

graphical.target @46.678s
└─multi-user.target @46.676s
  └─kerneloops.service @42.828s +8ms
    └─network-online.target @42.827s
      └─NetworkManager-wait-online.service @34.412s +8.414s
        └─NetworkManager.service @31.018s +3.392s
          └─dbus.service @30.460s
            └─basic.target @30.247s
              └─sockets.target @30.247s
                └─snapd.socket @30.189s +58ms
                  └─sysinit.target @30.188s
                    └─systemd-timesyncd.service @29.988s +199ms
                      └─systemd-tmpfiles-setup.service @29.489s +477ms
                        └─systemd-journal-flush.service @4.057s +25.431s
                          └─systemd-journald.service @3.330s +725ms
                            └─systemd-journald-dev-log.socket @3.329s
                              └─system.slice @3.323s
                                └─-.slice @3.302s

edit 1 : systemd-analyze blame

    25.431s systemd-journal-flush.service
         18.934s dev-sda7.device
         13.422s systemd-udevd.service
         12.897s snap-gnome\x2d3\x2d26\x2d1604-74.mount
         12.810s snap-gnome\x2dcharacters-139.mount
         12.798s snap-gnome\x2dlogs-45.mount
         12.253s plymouth-quit-wait.service
         11.904s snap-vlc-1049.mount
          9.220s snap-core-6350.mount
          8.414s NetworkManager-wait-online.service
          5.102s bolt.service
          3.703s mnt-01D306309612D5D0.mount
          3.436s accounts-daemon.service
          3.404s udisks2.service
          3.392s NetworkManager.service
          3.231s ModemManager.service
          3.105s mnt-3AB82379B82332B5.mount
          2.964s snapd.service
          2.427s systemd-fsck@dev-disk-by\x2duuid-d71546ea\x2d38ec\x2d431c\x2d80
          2.425s networkd-dispatcher.service
          2.243s networking.service
          2.192s polkit.service
          2.131s systemd-fsck@dev-disk-by\x2duuid-DE40\x2d72B8.service
lines 1-23

journactl --list-boots gives me this

11 21ac57ee5a764076bd4ca2f0d606f578 Wed 2019-07-17 09:37:48 IST—Wed 2019-07-17 
-10 3d6b343e32cf472682f7545c397f5b13 Wed 2019-07-17 10:06:34 IST—Wed 2019-07-17 
 -9 73a93657152f4bd38024a55300ece05b Wed 2019-07-17 10:20:24 IST—Wed 2019-07-17 
 -8 bb2608692ac9477f94b0301c0ebb4f42 Wed 2019-07-17 10:25:31 IST—Wed 2019-07-17 
 -7 2f956a25f9ac4c4493a0d9a248f22713 Wed 2019-07-17 11:34:54 IST—Wed 2019-07-17 
 -6 8f26b32c7a3e4d3bb2346abf16be3e07 Sat 2019-07-20 22:38:05 IST—Sat 2019-07-20 
 -5 799bf58a9df54ea3839d15dc26937384 Sun 2019-07-21 18:55:55 IST—Sun 2019-07-21 
 -4 60498b3ccaee455ba1b33abc14c45bc7 Sun 2019-07-21 13:40:40 IST—Sun 2019-07-21 
 -3 c493bf336d684eefa7f79bcbcca17e04 Sun 2019-07-21 19:51:29 IST—Sun 2019-07-21 
 -2 614ee7d9e42d40eeb632b2ff38444026 Sun 2019-07-21 15:00:38 IST—Sun 2019-07-21 
 -1 1a3ce75054b1485c9ee3b16e55e1c5b4 Sun 2019-07-21 15:10:48 IST—Sun 2019-07-21 
  0 25217cacd68d45d5bff816038ce225d8 Sun 2019-07-21 15:37:19 IST—Sun 2019-07-21 

journalctl --disk-usage gives this

Archived and active journals take up 96.0M in the file system.

  • journalctl --list-boots and journalctl --disk-usage Please edit your question for output. – nobody Jul 21 at 10:05
0

You have persistent journal enabled. Make sure in /etc/systemd/journald.conf the row Storage=auto is set. sudo journalctl --rotate Rotate journal files. and sudo journalctl --vacuum-time=1s

After that sudo rm -rf /var/log/journal

Reboot. Is boot faster?

  • i didnt see much difference systemd-analyze blame 15.487s systemd-modules-load.service this is something new, although journal is not showing now which is good thing but still boot time is 53 seconds almost same as before – Pulkit Gupta Jul 22 at 11:19
  • systemctl status systemd-modules-load.service please. sometimes I hate systemd. – nobody Jul 22 at 11:45
  • systemd-modules-load.service - Load Kernel Modules Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static; ven Active: active (exited) since Mon 2019-07-22 18:52:35 IST; 5min ago Docs: man:systemd-modules-load.service(8) man:modules-load.d(5) Process: 269 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status= Main PID: 269 (code=exited, status=0/SUCCESS) Warning: Journal has been rotated since unit was started. Log output is incomple – Pulkit Gupta Jul 22 at 13:27
  • I am having the same problem: askubuntu.com/questions/1161081/… I tried as nobody suggested to no avail. – Max Jul 27 at 8:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.