0

I have a small netbook and the writing cursor pretty much disappears when i move it around with the arrows in docs. I switched from Ubuntu where I had the Cursor Blinking off in Universal Access. That use to solve the problem.

  • 1
    What release of Lubuntu? An old one using LXDE or a modern one with LXQt? – guiverc Jul 21 at 8:08
  • Have you tried changing the cursor to a different one, in my play just now I've found some have very thin text cursors, whilst others have much thicker (and easier to spot). Refer manual.lubuntu.me/3/3.2/3.2.2/appearance.html?highlight=cursor – guiverc Jul 21 at 8:18
  • I have lubuntu 18.04 with LXDE – knut Jul 21 at 9:08
0

There's a short answer and a long answer to this.

Short answer

Lubuntu 18.04/LXDE

Sorry, there is no easily accessible option.

However, there is a hidden feature in LXSession that can help. You can change the config like so:

~/.config/lxsession/Lubuntu/desktop.conf
[GTK]
iNet/CursorBlink=no

and log out and log back in again to make the change.

Lubuntu >18.04/LXQt

lxqt-config-input offers an option to adjust the blink rate. To set it to non-blinking:

  1. Navigate to Menu » Preferences » LXQt Settings » Keyboard and Mouse » Keyboard.
  2. Set the Cursor flash time to 0ms.
  3. Click Apply.
  4. Click Close.

The Lubuntu Manual covers lxqt-config-input in greater detail.

Long answer

Technically, both solutions are only changing the settings for the underlying toolkit— GTK and Qt, respectively. In ≤18.04/LXDE, Lubuntu used mostly GTK apps, while after it was mostly Qt apps. That doesn't mean you couldn't install Qt apps in the mainly GTK system and vice versa. The changes above would not affect those "foreign" apps. The more general solution for the two respective toolkits follows.

GTK

Change the config for both current GTK versions:

~/.config/gtk-2.0/settings.ini and ~/.config/gtk-3.0/settings.ini
[Settings]
gtk-cursor-blink = false

Qt

This should be a simple matter of changing the Qt config with the likes of the following:

~/.qt/qtrc
[General]
cursorFlashTime=0
~/.config/Trolltech.conf and ~/.config/QtProject.conf
[Qt]
cursorFlashTime=0

or through the qtconfig application (see the qt-qt4config package in 18.04) via Interface » Cursor Flash Time » No Blinking but I could not get this to work in 18.04.

There is a page that covers this topic more generally for a variety of different applications, toolkits, and desktop environments that would be good to consult for any edge cases.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.