0

I'm using Ubuntu 16.04. I just installed mpd and ncmpcpp. Whenever I play any audio file, ncmpcpp detects the file and says it is playing, but no actual audio is playing. I followed this tutorial on installing and configuring both mpc and ncmpcpp. This is my mpd configuration:

music_directory     "~/Music"
playlist_directory      "~/Playlists"
db_file         "~/.local/share/mpd/mpd.db"
log_file            "~/.local/share/mpd/mpd.log"
pid_file            "~/.local/share/mpd/mpd.pid"
state_file          "~/.local/share/mpd/mpd.state"
sticker_file            "~/.local/share/mpd/sticker.sql"

bind_to_address     "127.0.0.1"
log_level           "default"
restore_paused "yes"
metadata_to_use "artist,album,title,track,name,genre,date"
auto_update "yes"

input {
        plugin "curl"
}

audio_output {
    type        "pulse"
    name        "pulse audio"
}

audio_output {
    type        "fifo"
    name        "mpd_fifo"
    path        "/tmp/mpd.fifo"
    format      "44100:16:2"
}

EDIT: I would like to also clarify that I tried to install the latest version as it says in this answer, but I get this message for one of the packages:

E: Package 'libsystemd-daemon-dev' has no installation candidate

So, I download the .deb file and tried to install it from there. When I run "sudo dpkg -i" and the path to the file, I get this error:

dpkg: error processing package libsystemd-daemon-dev (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libsystemd-daemon-dev
0

I found the answer to my own problem. I had to install the PulseAudio (What I'm using) GUI:

sudo apt-get install pavucontrol

Run it, and fix the problem. I suppose for those using alsa it would the mixer, and so on for other sound server programs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.