2

had many issues getting Ubuntu up an running on this laptop. Initially there was issues with secure-boot (which is now off), and following that the installer was failing with "allow proprietary drivers" checked.

Effectively I now cannot get the graphics drivers to install properly. I tried various versions, and though according to nvidias site, nvidia-430 should work, I've found that nvidia-396 is the only thing that doesn't break xorg - that being said when active, checking ScreenFetch and "about" it still shows my GPU as Intel.

nvidia-settings appears to switch between the two fine. But nvidia-smi can't communicate with the driver, so something must be going wrong, and intel is being used as a fallback.

Can anybody help me diagnose why things are failing?

Boot options

cat /etc/default/grub

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash quiet acpi_rev_override=1 acpi_osi=Linux nouveau.modeset=0 pcie_aspm=force drm.vblankoffdelay=1 scsi_mod.use_blk_mq=1 nouveau.runpm=0 mem_sleep_default=deep pti=off spectre_v2=off l1tf=off nospec_store_bypass_disable no_stf_barrier"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

nvidia-smi

NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

ps -efly | grep Xorg

S root      6104  1516  2  80   0 34668 106513 -     23:23 tty7     00:00:15 /usr/lib/xorg/Xorg -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
S nemo     13827 13527  0  80   0  1096  5384 pipe_w 23:35 pts/3    00:00:00 grep --color=auto --exclude-dir=.bzr --exclude-dir=CVS --exclude-dir=.git --exclude-dir=.hg --exclude-dir=.svn Xorg

cat /var/log/gpu-manager.log

log_file: /var/log/gpu-manager.log
last_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
new_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
can't access /run/u-d-c-nvidia-was-loaded file
can't access /opt/amdgpu-pro/bin/amdgpu-pro-px
Looking for nvidia modules in /lib/modules/4.19.14-041914-generic/updates/dkms
Looking for amdgpu modules in /lib/modules/4.19.14-041914-generic/updates/dkms
Is nvidia loaded? no
Was nvidia unloaded? no
Is nvidia blacklisted? no
Is intel loaded? yes
Is radeon loaded? no
Is radeon blacklisted? no
Is amdgpu loaded? no
Is amdgpu blacklisted? no
Is amdgpu versioned? no
Is amdgpu pro stack? no
Is nouveau loaded? no
Is nouveau blacklisted? yes
Is nvidia kernel module available? no
Is amdgpu kernel module available? no
Vendor/Device Id: 8086:3e9b
BusID "PCI:0@0:2:0"
Is boot vga? yes
Vendor/Device Id: 10de:1c20
BusID "PCI:1@0:0:0"
Is boot vga? no
Error: can't access /sys/bus/pci/devices/0000:01:00.0/driver
The device is not bound to any driver.
Skipping "/dev/dri/card0", driven by "i915"
Skipping "/dev/dri/card0", driven by "i915"
Skipping "/dev/dri/card0", driven by "i915"
Found "/dev/dri/card0", driven by "i915"
output 0:
    card0-eDP-1
Number of connected outputs for /dev/dri/card0: 1
Does it require offloading? yes
last cards number = 2
Has amd? no
Has intel? yes
Has nvidia? yes
How many cards? 2
Has the system changed? No
Intel IGP detected
Desktop system detected
or laptop with open drivers
Nothing to do

xorg.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 430.26


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

.xsession-errors

us-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting XAUTHORITY=/home/nemo/.Xauthority
dbus-update-activation-environment: setting GTK_MODULES=gail:atk-bridge
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting LANG=en_GB.UTF-8
dbus-update-activation-environment: setting GDM_LANG=en_GB
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting MANDATORY_PATH=/usr/share/gconf/i3.mandatory.path
dbus-update-activation-environment: setting S_COLORS=auto
dbus-update-activation-environment: setting XDG_GREETER_DATA_DIR=/var/lib/lightdm-data/nemo
dbus-update-activation-environment: setting USER=nemo
dbus-update-activation-environment: setting DESKTOP_SESSION=i3
dbus-update-activation-environment: setting DEFAULTS_PATH=/usr/share/gconf/i3.default.path
dbus-update-activation-environment: setting PWD=/home/nemo
dbus-update-activation-environment: setting HOME=/home/nemo
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting XDG_SESSION_TYPE=x11
dbus-update-activation-environment: setting XDG_DATA_DIRS=/usr/share/i3:/usr/local/share:/usr/share:/var/lib/snapd/desktop
dbus-update-activation-environment: setting XDG_SESSION_DESKTOP=i3
dbus-update-activation-environment: setting GTK_MODULES=gail:atk-bridge
dbus-update-activation-environment: setting SHELL=/usr/bin/zsh
dbus-update-activation-environment: setting XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0
dbus-update-activation-environment: setting IM_CONFIG_PHASE=1
dbus-update-activation-environment: setting XDG_CURRENT_DESKTOP=i3
dbus-update-activation-environment: setting GPG_AGENT_INFO=/run/user/1000/gnupg/S.gpg-agent:0:1
dbus-update-activation-environment: setting SHLVL=1
dbus-update-activation-environment: setting LANGUAGE=en_GB:en
dbus-update-activation-environment: setting GDMSESSION=i3
dbus-update-activation-environment: setting LOGNAME=nemo
dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
dbus-update-activation-environment: setting XDG_RUNTIME_DIR=/run/user/1000
dbus-update-activation-environment: setting XAUTHORITY=/home/nemo/.Xauthority
dbus-update-activation-environment: setting XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session2
dbus-update-activation-environment: setting XDG_CONFIG_DIRS=/etc/xdg/xdg-i3:/etc/xdg
dbus-update-activation-environment: setting PATH=/home/nemo/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin
dbus-update-activation-environment: setting _=/usr/bin/dbus-update-activation-environment
polybar|warn:  The config parameter `bar/top.border-bottom` is deprecated, use `bar/top.border-bottom-size` instead.
polybar|error: Disabling module "xworkspaces" (reason: Missing parameter "module/xworkspaces.type")
polybar|error: Disabling module "wireless-network" (reason: Invalid network interface "net1")
polybar|error: Disabling module "wireless-network" (reason: Invalid network interface "net1")
polybar|error: Disabling module "wired-network" (reason: Invalid network interface "net0")
polybar|error: Failed to restack bar window
[7456:7456:0720/232429.787615:ERROR:sandbox_linux.cc(368)] InitializeSandbox() called with multiple threads in process gpu-process.
[7409:7448:0720/232429.856252:ERROR:data_store_impl.cc(131)] Failed to open Data Reduction Proxy DB: 3
[7456:7456:0720/232430.015873:ERROR:buffer_manager.cc(488)] [.DisplayCompositor]GL ERROR :GL_INVALID_OPERATION : glBufferData: <- error from previous GL command
[7456:7456:0720/232536.625368:ERROR:buffer_manager.cc(488)] [.DisplayCompositor]GL ERROR :GL_INVALID_OPERATION : glBufferData: <- error from previous GL command
[7456:7456:0720/232754.931509:ERROR:buffer_manager.cc(488)] [.DisplayCompositor]GL ERROR :GL_INVALID_OPERATION : glBufferData: <- error from previous GL command
[7456:7456:0720/232758.093049:ERROR:buffer_manager.cc(488)] [.DisplayCompositor]GL ERROR :GL_INVALID_OPERATION : glBufferData: <- error from previous GL command
[7456:7456:0720/232803.960556:ERROR:buffer_manager.cc(488)] [.DisplayCompositor]GL ERROR :GL_INVALID_OPERATION : glBufferData: <- error from previous GL command
[7456:7456:0720/232805.870369:ERROR:buffer_manager.cc(488)] [.DisplayCompositor]GL ERROR :GL_INVALID_OPERATION : glBufferData: <- error from previous GL command
[7456:7456:0720/233028.760073:ERROR:buffer_manager.cc(488)] [.DisplayCompositor]GL ERROR :GL_INVALID_OPERATION : glBufferData: <- error from previous GL command

edit:

Confirmed the above I believe, by running commands in TTY after installing the 430 driver. Note that there is no GUI at all here.

Sun Jul 21 01:03:43 2019       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 430.26       Driver Version: 430.26       CUDA Version: 10.2     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 106...  Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   55C    P8     5W /  N/A |      8MiB /  6078MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0      1583      G   /usr/lib/xorg/Xorg                             5MiB |
+-----------------------------------------------------------------------------+

ps -efly | grep Xorg

S root      1583  1487  0  80   0 48580 65741 -      01:00 tty7     00:00:00 /usr/lib/xorg/Xorg -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
S nemo      7027  4954  0  80   0   940  5384 pipe_w 01:06 tty4     00:00:00 grep --color=auto --exclude-dir=.bzr --exclude-dir=CVS --exclude-dir=.git --exclude-dir=.hg --exclude-dir=.svn Xorg

Edit:

Happy to provide any additional details that may be of use for anybody. Need this so that I can get my second monitor working for work.

Update:

Still had no luck. I think the main issue is I don't know what logs to read.

Edit: A few others are having the same issue over at https://ubuntuforums.org/showthread.php?t=2423396

Edit: additional logs

Xorg.0.log https://pastebin.com/FKh3C9Ta

Sun Aug 11 20:27:54 2019       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 430.40       Driver Version: 430.40       CUDA Version: 10.1     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 106...  Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   51C    P8     5W /  N/A |      8MiB /  6078MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0      1555      G   /usr/lib/xorg/Xorg                             5MiB |
+-----------------------------------------------------------------------------+

And also I get the output PKCS#7 signature not signed with a trusted key during booy.

  • 1
    I suggest that you remove Nvidia drivers and reinstall them the proper way. Check this link – singrium Aug 7 at 19:35
  • 1
    Did you get any errors? – singrium Aug 8 at 21:20
  • 1
    Did you get the back screen after you installed the drivers or after installing Cuda? – singrium Aug 8 at 21:24
  • 2
    I wouldn't worry about PKCS#7 signature I get it too and my Nvidia card works fine. – WinEunuuchs2Unix Aug 14 at 11:01
  • 2
    I would remove drm.vblankoffdelay=1 from grub kernel parameters. Also consider nvidia-384 which works just fine for me and I know people with 1060 cards use it. – WinEunuuchs2Unix Aug 14 at 11:26
2
+50

It might be an "18.04 thing": External monitor not detected on Ubuntu 18.04. I've never experienced it upgrading to 18.04 or 19.04 but I'm already using LightDM.

I have a close but not identical system. Dell AW 17R3, I-7 6700HQ Intel HD 530 iGPU, nVidia GTX 970M GPU. Besides comments above, I'll share my xorg.conf in hopes it might help:

$ cat /etc/X11/xorg.conf

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Monitor"
    Identifier "DP-1-1"
    Modeline "3840x2160_54.00"  637.50  3840 4152 4568 5296  2160 2163 2168 2230 -hsync +vsync
    Option "PreferredMode" "3840x2160_54.00"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:0@0:2:0"
    Option "AccelMethod" "None"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1@0:0:0"
    Option "ConstrainCursor" "off"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration" "on"
    Option "IgnoreDisplayDevices" "CRT"
EndSection

Ignore the DP-1-1 monitor section. It is only for my 3rd monitor which has a finicky; 4K TV, or Thuderbolt 3 adapter, or cable or all three.

  • Hey, I'm also using lightdm but I will have a run through and switch back and forth to see if it has any effect, because I've had video driver issues that tied into lightdm before. Thanks for the xorg config too. I notice a few things that are different so it may be something I can play with at the weekend. – Ben Hayward Aug 15 at 19:31
2

Some of the Nvidia drivers that you tried to install break X.Org indicates that it is possible the apt was not integrating properly with the currently installed version of X.Org when you tried to install the Nvidia driver. The Nvidia driver has a number of dependencies, including an X.Org dependency package. To simplify the process of making all the dependencies work together use the autoinstall command. The autoinstall command of ubuntu-drivers installs drivers that are appropriate for automatic installation including their dependencies. Open the terminal and type:

sudo ubuntu-drivers autoinstall
sudo reboot

Please note that you may get a broken packages error message when trying to run sudo ubuntu-drivers autoinstall unless you uninstall the existing Nvidia packages and reboot before trying to automatically install any new Nvidia packages.

Another tip is to use the --simulate option of apt to simulate what would be installed or changed by an apt command without actually changing anything. The --simulate option can be run without sudo as a normal user, for example:

apt install --simulate nvidia-driver-430
  • Hey, tried to us this method already unfortunately. Thank you for your time and answer though, I've learned things that I did not know about xorg, apt and the role of ubuntu-drivers autoinstall. Many thanks! – Ben Hayward Aug 15 at 19:28
1

In your situation I would likely format the system (all the drives on which an OS is installed) and start from scratch. Or perhaps the Ubuntu installer is corrupted.

  • Hey, I have had this issue since I did fresh install, and am weary of doing it again, as I have a heavy stack configured and set up for my job. It's a task to get up and running on a new machine that I just don't have time to do – Ben Hayward Aug 15 at 19:34
  • @BenHayward Fresh install of ubuntu, or literal fresh install, meaning formatting all the drives, completely removing all the operating systems? (You should try Xubuntu; for I am weary working on systems that don't work from the get-go. And once in Xubuntu install Synaptic Package Manager to install or delete software, avoid 'gnome-software' or the 'Snap store' to do that.) I know this is not a direct solution to your problem, but something as critical as GPU drivers should work effortlessly. – xubuntu Aug 16 at 6:30
  • I could try sideloading it maybe; I use i3wm, and would find it a very hard to switch to a non-tiling wm. That being said side-loading it maybe synaptic package manager will be able to help me out! Will try it over the weekend thank you. – Ben Hayward Aug 16 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.