1

I have installed Ubuntu 18.04.2 server and then installed ubuntu-unity-desktop, and Network Manager is hosed. This problem has been reported more than once (Ethernet device not managed) and I am sure this question will be marked as a duplicate, but I have tried all the remedies and the problem has not been resolved.

I have tried:

  • editing /etc/NetworkManager/NetworkManager.conf.
  • editing /usr/lib/NetworkManager/conf.d/10-globally-managed-devices.conf.
  • an empty /usr/lib/NetworkManager/conf.d/10-globally-managed-devices.conf.

What finally fixed it was editing /etc/netplan/*.yaml

@heynnema - Why was it the wrong thing to do? It seems to have worked. My /etc/interfaces files is nothing but comments. My netplan yaml is what I finally edited, and is:

network:
  version: 2
  renderer: NetworkManager

lshw reports correctly ehat my only network interface is a RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.