5

I have dark mode working on chrome's internal pages in Windows 10. Is it not implemented in the Ubuntu version?

I'm using chrome version 75.0. My theme is Adwaita-dark.

15

On my system, I have the dark mode active:

Dark mode in Chrome 75

I need to do two things:

  • launch the browser using google-chrome-stable --enable-features=WebUIDarkMode --force-dark-mode and
  • set the browser to use the Classic option rather than GTK+ as shown in the image below. Doing so makes the choice your GTK theme irrelevant:

Use Classic, not GTK+ in chrome://settings/?search=themes

Use Classic, not GTK+


Unfortunately, not all internal pages are themed. Opening many of the urls in chrome://chrome-urls/ will confirm that. It's not clear if or when they'll ever get round to that!

  • 1
    Finally.. Thanks! – lamino Jul 24 '19 at 15:03
14

Note: as of chrome Version 78.0.3904.87 (Official Build) (64-bit) you can easliy turn chrome's internal pages to dark mode,its under chrome flags by default

  • run chrome://flags in the url
  • search for dark and you should see this option Force Dark Mode for Web Contents just enable it and relaunch chrome.

this is how it looks enter image description here

for those who don't have the above option under flags To enable dark mode on Ubuntu, you need to edit the google-chrome.desktop file.

If you use GNOME desktop, simply run the command below which opens up the required file in editable format. If not, open the file in a text editor of your choice

sudo -H gedit /usr/share/applications/google-chrome.desktop

All you have to do is search for two lines and add a dark mode flag in front of them.

  1. Search for

    Exec=/usr/bin/google-chrome-stable %U
    

    and replace it with:

    Exec=/usr/bin/google-chrome-stable %U --force-dark-mode
    
  2. Search for

    Exec=/usr/bin/google-chrome-stable
    

    and add the dark mode flag after it like this:

    Exec=/usr/bin/google-chrome-stable --force-dark-mode
    

Once you have done these changes, simply try restarting chrome. If that doesn't work, rebooting your Ubuntu system should do the job.

For me rebooting my Ubuntu 18.04 system worked. Also note that if you update the chrome app, the changes will be gone, since the file will be overwritten.

  • 1
    Instead of modifying /usr/share/applications/google-chrome.desktop, the file can be copied into ~/.local/share/applications/google-chrome.desktop and modified without root access. This file will take precedence over the global desktop file. – Remco Haszing Jan 15 at 12:03
0

Just paste

chrome://flags 

in the search bar, and in the opened page, search for 'dark' and find

Force Dark Mode for Web Contents

Enable this thing, and you're done.
Now you've got the dark mode.

New contributor
Shah Vipul is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
-1

I would highly recommend installing Dark Reader which intelligently scans the CSS of the page to keep background dark and adjust foreground colors accordingly. Here is a snippet showing dark reader in action

Original Original

Dark reader Dark Reader modified

New contributor
Siddhesh Rane is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • Why downvoting this post? Is there something against Dark reader chrome extension? – Jeanba yesterday

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.