0

Unable to ping to only Windows guest. able to ping to other guest.

HOST os Ubuntu 18.4.2

What i did so far- Tried to change device to virtio,rtl8329,e1000

Internet is working on guest.

Windows 7 guest firewall disabled.

installed virtio driver for windows from -https://launchpad.net/kvm-guest-drivers-windows/+download

https://ubuntuforums.org/showthread.php?t=2308987

from host able to ping to centos guest in same network and host.

Here is network configuration of host.

root@hp-e840-g1:/var/lib/libvirt/dnsmasq# ifconfig 
br0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::3832:b6ff:fed3:b592  prefixlen 64  scopeid 0x20<link>
        ether 3a:32:b6:d3:b5:92  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1272  bytes 213475 (213.4 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

br0:avahi: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 169.254.10.198  netmask 255.255.0.0  broadcast 169.254.255.255
        ether 3a:32:b6:d3:b5:92  txqueuelen 1000  (Ethernet)

enp0s25: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether d0:bf:9c:1f:6d:7b  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 20  memory 0xd0700000-d0720000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 18229  bytes 1627449 (1.6 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 18229  bytes 1627449 (1.6 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

virbr0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.122.1  netmask 255.255.255.0  broadcast 192.168.122.255
        ether 52:54:00:f6:8c:87  txqueuelen 1000  (Ethernet)
        RX packets 27291  bytes 1676922 (1.6 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 21479  bytes 53057319 (53.0 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

vnet0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::fc54:ff:fe63:38bc  prefixlen 64  scopeid 0x20<link>
        ether fe:54:00:63:38:bc  txqueuelen 1000  (Ethernet)
        RX packets 404  bytes 44813 (44.8 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 358  bytes 23713 (23.7 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

vnet1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::fc54:ff:fe05:1413  prefixlen 64  scopeid 0x20<link>
        ether fe:54:00:05:14:13  txqueuelen 1000  (Ethernet)
        RX packets 634  bytes 50098 (50.0 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 8973  bytes 667052 (667.0 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlo1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 172.20.10.5  netmask 255.255.255.240  broadcast 172.20.10.15
        inet6 fe80::2064:887d:4812:fd7d  prefixlen 64  scopeid 0x20<link>
        ether ac:fd:ce:00:c4:6d  txqueuelen 1000  (Ethernet)
        RX packets 105684  bytes 110034160 (110.0 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 70214  bytes 9358661 (9.3 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

any help really appreciated! Thanks

  • Thank you guys, the issue has been resolved by my self. Windows 7 was blocking ICMP traffic, it was weird that i disabled firewall and service not no luck. ;) After i enabled firewall rules to allow icmp packet then it worked. – JackyChan Jul 22 at 10:25
0

Thank you guys, the issue has been resolved by my self.

Windows 7 was blocking ICMP traffic, it was weird that i disabled firewall and service not no luck. ;)

After i enabled firewall rules to allowed icmp packet then it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.