1

First: I have tried for MANY hours and numerous fixes to try to get this to work. So I am sorry that this is filled with questions that have been asked multiple times. Second: I am not very good with linux, so please excuse my ignorance

  • I could not get an external monitor to be recognized, so I installed nvidia driver 390 as it was recommended
  • Monitor still was not recognized, so I opened x server and it looked like this: xserver
  • one of the fixes for xserver was to purge Nvidia drivers and reinstall (390 again), so I did
  • now my system is booting to a black screen, and only works in recovery mode
  • I tried newer drivers, including one downloaded directly from Nvidia (418 I believe), that installation failed. So I downloaded it through the terminal. Still black screen
  • secure boot is disabled in the bios
  • my system is set up for dual boot on two separate SSD's
  • ever since upgrading to 18.04 my computer will not shut down properly or reboot, it gets to the end of the process and never powers off. I wiped the drive and did a fresh install of Ubuntu, but still isn't working (apparently this can be an issue stemming from the graphics card driver as well). This i can live with, black screens I cannot

Thoughts, feelings, suggestions? Helps would be appreciated!

More screenshots for fun: something somethingelse recommended

lshw -numeric -C display:
  *-display UNCLAIMED       
       description: VGA compatible controller
       product: GP107M [GeForce GTX 1050 Ti Mobile] [10DE:1C8C]
       vendor: NVIDIA Corporation [10DE]
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:de000000-deffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:df000000-df07ffff
  *-display UNCLAIMED
       description: VGA compatible controller
       product: Intel Corporation [8086:591B]
       vendor: Intel Corporation [8086]
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 04
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:dd000000-ddffffff memory:b0000000-bfffffff ioport:f000(size=64) memory:c0000-dffff

-SCREEN SHOT since apparently we do not like new lines around here.... : lshw

More stuff:

chris:~$ nvidia-smi
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.
-tried switching prime select to intel and back, no bueno
- kernel is up to date
  • Welcome to AskUbuntu, hope you find your answer here. Firstly, get the hardware info such as the output of "lshw -numeric -C display". Please add these info to your original post. I use multiple nvidia GPU with Ubuntu 18.04, so I may be able to help if your setup is similar to mine. – Bernard Wei Jul 19 at 18:28
  • For Nvidia if you already installed the drivers correctly, just disable Secure Boot. – GabrielaGarcia Jul 19 at 23:33
  • Ubuntu 19.04 Ryzen gpu, this worked for me askubuntu.com/questions/1135590/… Removing /lib/firmware/amdgpu/raven_dmcu.bin and running sudo update-initramfs -u -k all solved this problem. I get by now just deleting the file and no update part. – pierrely Jul 20 at 6:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.