0

What are the best practices to configure BIOS/Firmware settings for dual boot Ubuntu install alongside Windows 10?

I've turned off the "Fast Initialization" option on my computer, just because I've tried two other times a year ago and I failed. In that times, I've followed the tutorial the right way (I think).

When it failed the last time, it was when the GRUB leaded only to Ubuntu, if I selected the Windows option, the GRUB returned again, leading me to an infinite loop between Windows and GRUB. My files, however, weren't lost.


*I'm installing Ubuntu 18.04 because the 19 version gave Kernel Panic at me.

Here is the picture of the error: https://imgur.com/s4Rzb9I <-- 19 Ubuntu ISO

The error when the 18.04 version is booted is: https://imgur.com/etezYw5


P.S.: Detailing my BIOS and Board (informations from CPU-Z):

UEFI: Yes

vendor: ASRock

model: H61M-HVS

Complete System details: https://pastebin.com/izzX7Gv4~


EDIT2: In conversation by chat, I've put the 18 iso and the problem is the same. When I put the ISO and change the boot order by ASRock BIOS GUI, booting by USB Flash Drive (not UEFI, there is an option for this too), it loads the screen with an icon of accessibility and another one for a keyboard, then there is a black screen putting an error (the image above)

I've tried to put the same USB Flash Drive in another computer, but another error is gave to me: https://imgur.com/FKjqKgc <-- Tested with 18.04 Ubuntu ISO


EDIT3: I'm now closing this question only related to dual-boot tips. In relation to the problem in BIOS, I'll create another post.

  • 1
    Secure Boot can also, sometimes, be problematic, if not disabled for the installation of the new OS. Once installed and both Windows and Ubuntu reboot OK, you can turn it back on. – K7AAY Jul 19 at 18:25
  • Are you doing fresh install for both, or do you have windows 10 already installed? – Bernard Wei Jul 19 at 18:35
  • 2
    You show BIOS from 2012, is that BIOS only or UEFI. It was in 2012 and release of Windows 8 that Microsoft required vendors to install in UEFI boot mode with gpt partitioning. If UEFI/BIOS is that old there should be an update available from vendor also. You need to update it. What brand/mode system. UEFI/BIOS settings vary by vendor a lot. – oldfred Jul 19 at 18:45
  • @oldfred Hmm... Will that harm my 18's installation too? – Dyefferson Azevedo Jul 19 at 19:03
  • @BernardWei Windows 10 is already installed – Dyefferson Azevedo Jul 19 at 19:04
1

There are a couple of things to check:

  1. install Ubuntu the same way windows is installed: legacy or EFI. Otherwise you can only boot one and need to pick the other way by entering BIOS and selecting it.
  2. disable fast boot in BIOS if available.
  3. disable secure boot in BIOS if available.
  4. if you use an SSD set it to AHCI.

If the installer is created with EFI enabled you can rename (or remove) /sys/firmware/efi/ on the pendrive (by mounting it as writeable) and it will install the system in legacy.

Command line to check if the live session was started with UEFI or legacy BIOS:

$ [ -d /sys/firmware/efi ] && echo UEFI || echo BIOS
UEFI

It is easiest to create unallocated space on the partitions you want to use for Ubuntu. Makes it easier to recognize. Try to put base Ubuntu (/) on an SSD if available. Quicker boot and quicker loading of configuration. In theory you can use D: to store your personal files, though I would advice to create a partition to store these.

  • How to check if Windows is legacy BIOS or UEFI? Your command line instructions were for linux terminal, wasn't it? – Dyefferson Azevedo Jul 20 at 12:57
  • we only support Ubuntu on here so yes. I do not know how to check on windows (XP was my last one ;)) But you should be able to see it in BIOS at the "boot options". a bootable partition will state it is EFI – Rinzwind Jul 20 at 15:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.