1

enter image description here

Bluetooth does not turn on, no matter how hard I hit the ON button.

Here's what sudo rfkill list says

0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: hp-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
2: hp-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no

And here's the output of sudo lshw -class communication

*-communication
description: Communication controller
product: 8 Series HECI #0
vendor: Intel Corporation
physical id: 16
bus info: pci@0000:00:16.0
version: 04
width: 64 bits
clock: 33MHz
capabilities: pm msi bus_master cap_list
configuration: driver=mei_me latency=0
resources: irq:48 memory:b5718000-b571801f

Output of lspci | grep Realtek

02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader (rev 01)  
08:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL810xE PCI Express Fast Ethernet controller (rev 07)

Output of uname -r

4.18.0-25-generic

Output of lsusb

Bus 001 Device 003: ID 04f2:b40e Chicony Electronics Co., Ltd HP Truevision HD camera
Bus 001 Device 002: ID 8087:8000 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 003: ID 1c4f:0002 SiGma Micro Keyboard TRACER Gamma Ivory
Bus 002 Device 002: ID 04f3:0235 Elan Microelectronics Corp.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I also tried methods which are listed in answers to this question

Bluetooth not working on Ubuntu 16.04 LTS

########## wireless info START ##########

Report from: 22 Jul 2019 15:17 IST +0530

Booted last: 22 Jul 2019 00:00 IST +0530

Script from: 22 Oct 2018 03:34 UTC +0000

##### release ###########################

Distributor ID: Ubuntu
Description:    Ubuntu 18.04.2 LTS
Release:    18.04
Codename:   bionic

##### kernel ############################

Linux 4.18.0-25-generic #26~18.04.1-Ubuntu SMP Thu Jun 27 07:28:31 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Parameters: ro, quiet, splash, vt.handoff=1

##### desktop ###########################

Ubuntu

##### lspci #############################

08:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL810xE PCI Express Fast Ethernet controller [10ec:8136] (rev 07)
    Subsystem: Hewlett-Packard Company RTL810xE PCI Express Fast Ethernet controller [103c:220e]
    Kernel driver in use: r8169

0a:00.0 Network controller [0280]: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe [1814:3290]
    Subsystem: Hewlett-Packard Company Ralink RT3290LE 802.11bgn 1x1 Wi-Fi and Bluetooth 4.0 Combo Adapter [103c:18ec]
    Kernel driver in use: rt2800pci

##### lsusb #############################

Bus 001 Device 003: ID 04f2:b40e Chicony Electronics Co., Ltd HP Truevision HD camera
Bus 001 Device 002: ID 8087:8000 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 003: ID 04f3:0235 Elan Microelectronics Corp. 
Bus 002 Device 002: ID 1c4f:0002 SiGma Micro Keyboard TRACER Gamma Ivory
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

##### PCMCIA card info ##################

##### rfkill ############################

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: hp-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: hp-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no

##### secure boot #######################

'mokutil' is not installed (package "mokutil").

##### lsmod #############################

hp_wmi                 16384  0
sparse_keymap          16384  1 hp_wmi
wmi_bmof               16384  0
mxm_wmi                16384  1 nouveau
rt2800pci              16384  0
rt2800mmio             16384  1 rt2800pci
rt2800lib             114688  2 rt2800mmio,rt2800pci
rt2x00pci              16384  1 rt2800pci
rt2x00mmio             16384  2 rt2800mmio,rt2800pci
rt2x00lib              53248  5 rt2x00mmio,rt2x00pci,rt2800mmio,rt2800pci,rt2800lib
mac80211              802816  3 rt2x00pci,rt2x00lib,rt2800lib
cfg80211              667648  2 rt2x00lib,mac80211
eeprom_93cx6           16384  1 rt2800pci
wmi                    24576  4 hp_wmi,wmi_bmof,mxm_wmi,nouveau

##### interfaces ########################

[/etc/network/interfaces]
auto lo
iface lo inet loopback

##### ifconfig ##########################

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback <MAC address> brd <MAC address>
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp8s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether <MAC 'enp8s0' [IF1]> brd <MAC address>
3: wlp10s0f0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether <MAC 'wlp10s0f0' [IF2]> brd <MAC address>
    inet 192.168.43.170/24 brd 192.168.43.255 scope global dynamic noprefixroute wlp10s0f0
       valid_lft 3394sec preferred_lft 3394sec
    inet6 fe80::3762:a3dc:9f6f:80de/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

##### iwconfig ##########################

lo        no wireless extensions.

enp8s0    no wireless extensions.

wlp10s0f0  IEEE 802.11  ESSID:"Akash"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: <MAC 'Akash' [AC1]>   
          Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
          Retry short  long limit:2   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=55/70  Signal level=-55 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:43   Missed beacon:0

##### route #############################
  • Could it be that Bluetooth is switched off at the BIOS level? And are you sure - sorry to be so obvious here - there isn't a hardware switch? – Jos Jul 19 '19 at 9:06
  • The hardware switch is set to ON – Akash Karnatak Jul 19 '19 at 9:58
  • What is your computer make and model? Your wifi card make and model? You may not even have bluetooth on your computer. – WinEunuuchs2Unix Jul 19 '19 at 15:12
  • HP Notebook - 14s-cr1005tu. My pc has bluetooth, it runs perfectly on windows. But now I want to switch to linux. – Akash Karnatak Jul 19 '19 at 15:27
  • Can you update your question with results from lspci | grep Realtek and uname -r? – WinEunuuchs2Unix Jul 19 '19 at 15:40
1

Long standing bug report

Three is a Launch Pad bug report on this WiFi card since 2013:

I suggest you subscribe to the bug report because the more people that do the quicker the bug gets solved. Also subscribe to the email chain for status updates.

There are too many fixes listed in Ask Ubuntu to pick a single one that will work for you. Here are the various questions you can check on the RT3290 though:

How to get WiFi Information

There is a diagnostics script you can run to analyze all things WiFi:

wget -N -t 5 -T 10 https://github.com/UbuntuForums/wireless-info/raw/master/wireless-info
chmod +x wireless-info
./wireless-info

It will create the file wireless-info.txt at which point you will need to use:

  • gedit wireless-info.txt
  • Highlight text from top of file to route section
  • Copy selected text to clipboard with Ctrl+C
  • Edit your question above and position cursor to bottom
  • Press Enter to insert new line if necessary
  • Paste text from clipboard with Ctrl+V
  • Highlight inserted text (it will take awhile) and press {} button to reformat text to code.

Now the bottom of your question will look something like this:

########## wireless info START ##########

Report from: 21 Jul 2019 10:42 MDT -0600

Booted last: 21 Jul 2019 00:00 MDT -0600

Script from: 22 Oct 2018 03:34 UTC +0000

##### release ###########################

Distributor ID: Ubuntu
Description:    Ubuntu 16.04.6 LTS
Release:    16.04
Codename:   xenial

##### kernel ############################

Linux 4.14.114-0414114-generic #201904270558 SMP Sat Apr 27 10:01:11 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Parameters: ro, noplymouth, fastboot, acpiphp.disable=1, pcie_aspm=force, vt.handoff=7, i915.fastboot=1, nopti, nospectre_v2, nospec, mem_sleep_default=deep

##### desktop ###########################

Ubuntu

##### lspci #############################

3b:00.0 Ethernet controller [0200]: Qualcomm Atheros Killer E2400 Gigabit Ethernet Controller [1969:e0a1] (rev 10)
    Subsystem: Device [0707:2400]
    Kernel driver in use: alx

3c:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32)
    Subsystem: Bigfoot Networks, Inc. QCA6174 802.11ac Wireless Network Adapter [1a56:1535]
    Kernel driver in use: ath10k_pci

##### lsusb #############################

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 003: ID 2109:0812 VIA Labs, Inc. VL812 Hub
Bus 002 Device 002: ID 2109:0812 VIA Labs, Inc. VL812 Hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 007: ID 1bcf:2b8c Sunplus Innovation Technology Inc. 
Bus 001 Device 005: ID 0cf3:e301 Atheros Communications, Inc. 
Bus 001 Device 003: ID 187c:0528 Alienware Corporation 
Bus 001 Device 011: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 010: ID 2109:2812 VIA Labs, Inc. VL812 Hub
Bus 001 Device 008: ID 413c:9016 Dell Computer Corp. 
Bus 001 Device 006: ID 0764:0501 Cyber Power System, Inc. CP1500 AVR UPS
Bus 001 Device 004: ID 04f9:024a Brother Industries, Ltd 
Bus 001 Device 002: ID 2109:2812 VIA Labs, Inc. VL812 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

##### PCMCIA card info ##################

##### rfkill ############################

0: dell-rbtn: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
8: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no

##### secure boot #######################

SecureBoot disabled

##### lsmod #############################

dell_wmi               16384  0
dell_smbios            16384  1 dell_wmi
wmi_bmof               16384  0
sparse_keymap          16384  1 dell_wmi
mxm_wmi                16384  0
ath10k_pci             53248  0
ath10k_core           417792  1 ath10k_pci
ath                    32768  1 ath10k_core
mac80211              925696  1 ath10k_core
cfg80211              733184  3 ath,mac80211,ath10k_core
wmi                    28672  3 dell_wmi,wmi_bmof,mxm_wmi
video                  45056  2 dell_wmi,i915

##### interfaces ########################

[/etc/network/interfaces]
auto lo
iface lo inet loopback

##### ifconfig ##########################

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback <MAC address> brd <MAC address>
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp59s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether <MAC 'enp59s0' [IF1]> brd <MAC address>
    inet 192.168.1.67/24 brd 192.168.1.255 scope global dynamic enp59s0
       valid_lft 82088sec preferred_lft 82088sec
    inet6 2001:56a:f117:600:11c1:654b:3cc9:3a43/64 scope global temporary dynamic 
       valid_lft 14655sec preferred_lft 14355sec
    inet6 2001:56a:f117:600:fcf0:956d:fa78:8f6/64 scope global mngtmpaddr noprefixroute dynamic 
       valid_lft 14655sec preferred_lft 14355sec
    inet6 fe80::1cd:2767:f2be:8f60/64 scope link 
       valid_lft forever preferred_lft forever
3: wlp60s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether <MAC 'wlp60s0' [IF2]> brd <MAC address>
    inet 192.168.1.68/24 brd 192.168.1.255 scope global dynamic wlp60s0
       valid_lft 82093sec preferred_lft 82093sec
    inet6 2001:56a:f117:600:c57b:316a:703d:9d66/64 scope global temporary dynamic 
       valid_lft 14655sec preferred_lft 14355sec
    inet6 2001:56a:f117:600:e0a7:e80e:e5d1:5853/64 scope global mngtmpaddr noprefixroute dynamic 
       valid_lft 14655sec preferred_lft 14355sec
    inet6 fe80::5b43:df9d:7566:888/64 scope link 
       valid_lft forever preferred_lft forever

##### iwconfig ##########################

enp59s0   no wireless extensions.

lo        no wireless extensions.

wlp60s0   IEEE 802.11  ESSID:"TELUS1213-5G"  
          Mode:Managed  Frequency:5.56 GHz  Access Point: <MAC 'TELUS1213-5G' [AN10]>   
          Bit Rate=6 Mb/s   Tx-Power=24 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=70/70  Signal level=-40 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:88   Missed beacon:0

##### route #############################
| improve this answer | |
  • did exactly as you said – Akash Karnatak Jul 22 '19 at 9:54
  • @AkashKarnatak I think I've finally found the problem. Please read revisions to answer. – WinEunuuchs2Unix Jul 22 '19 at 15:36
  • thnx my bluetooth is working now. – Akash Karnatak Jul 23 '19 at 2:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.