2

Thank you in advance to anyone who reads this and offers any suggestions that might help.

I have been working for over 3 days to find a solution and not being a 'power user' I have no real way of getting around without the mouse. We use this machine to run 2 businesses and are basically dead in the water =(

Our Dell Precision M6800 was happily running Ubuntu 17.? for about 1.5 years, and have just done a dist upgrade to 18.04.2. Now I can't click anything left or right-click on either the touchpad or wireless mouse and most of the keyboard shortcuts are broken.

When the ubuntu login screen pops up, mouse clicks work fine, but as soon as I log in they stop.

If I press CTRL + ALT + F1, the login screen reappears and mouse clicks work again, but as soon as I log in again, they stop.

CTRL + ALT + T does not work to open a terminal.
ALT + F2 does not work to open a quick terminal command box.
Basically, I can't get to a terminal window =(

After many hours of frustration trying many different things, I walked away for some time, when I came back the screen saver (black screen) had activated, and when I woke it up, then I discovered both these shortcut key commands to open a terminal worked, but still no mouse clicks.
Rebooting the computer repeats the same issues, so I have to wait at least 10 mins for the screen saver to activate to enable the shortcut keys to open a terminal.

The laptop is in a dock that feeds 2 external monitors and a wired keyboard. I disconnected it from the dock and rebooted so it was just running the laptop's own hardware, no change.

I have spent days researching forums of similar problems others have experienced and tried many of their suggestions including (not necessarily in this order):

  1. Software update to ensure any more changes available are applied
    $ sudo apt-get update $ sudo apt-get upgrade

  2. A suggestion to wake things up
    CTRL + ALT + F6 Sign in CTRL + ALT + F7

  3. Another one
    CTRL + ALT + F1 CTRL + ALT + F8 CTRL + ALT + F7

  4. Tried to update all the drivers to recommendations
    $ sudo ubuntu-drivers autoinstall

  5. Updated video drivers to recommended nvidia 418, blacklisted the nouveau drivers
    $ ubuntu-drivers devices $ sudo apt install nvidia-418 $ sudo bash -c "echo blacklist nouveau > /etc/modprobe.d/blacklist-nvidia-nouveau.conf" $ sudo bash -c "echo options nouveau modeset=0 >> /etc/modprobe.d/blacklist-nvidia-nouveau.conf" $ cat /etc/modprobe.d/blacklist-nvidia-nouveau.conf $ sudo update-initramfs -u

  6. Removed the nvidia video drivers and set it back to nouveau with:
    $ sudo apt install nouveau-firmware $ sudo apt purge nvidia-driver-418 $ sudo apt autoremove $ sudo apt install xserver-xorg-video-nouveau

  7. Reinstall inputattach
    $ sudo apt-get install --reinstall inputattach

  8. Reinstall xserver-xorg-input-all
    $ sudo apt-get --purge autoremove xserver-xorg-input-all && sudo apt-get install xserver-xorg-input-all

  9. remove and reinstate the mouse driver
    $ sudo modprobe -r psmouse
    $ sudo modprobe psmouse proto=imps

  10. Remove the synaptics and install libinput
    $ sudo apt-get update && sudo apt-get --auto-remove purge xserver-xorg-input-synaptics && sudo apt-get install xserver-xorg-input-libinput

  11. Fix Broken Ubuntu OS
    $ sudo rm /var/lib/apt/lists/lock $ sudo rm /var/lib/dpkg/lock $ sudo rm /var/lib/dpkg/lock-frontend $ sudo dpkg --configure -a $ sudo apt clean $ sudo apt update --fix-missing $ sudo apt install -f $ sudo dpkg --configure -a $ sudo apt upgrade $ sudo apt dist-upgrade

  12. Old trick some people found worked
    $ sudo metacity --replace
    (said it wasn't installed anyway)

  13. Remove any fragments of unity desktop
    $ sudo apt purge unity-session unity $ sudo apt autoremove

  14. Remove old version of gnome-tweak-tool
    $ sudo apt-get purge --auto-remove gnome-tweak-tool
    (said it wasn't installed anyway)

Did a reboot after trying each suggestion, nothing made any changes to the problems, only changing the video drivers affected the multi-screen positioning.

Also, I ran:
$ xinput -list
it said my mouse is: id=11
then I ran:
$ xinput -test 11
Then I clicked left, middle & right buttons, it showed:
button press 1 button release 1 button press 2 button release 2 button press 3 button release 3
Seems the clicks are registering.

Also another odd behavior I observed:
if I go: CTRL + ALT + F1 to take me back to the login screen, I then log in (and as mentioned all the mouse clicks work fine there so I can even click the login button!), but when I come back to the desktop, I can see a 2nd mouse pointer.
Only one moves as I move the mouse, and sometimes the other one disappears once the moving pointer enters the screen with the fixed pointer.
The moving pointer is black with a white border, the fixed pointer is white with a black border.
2 things both trying to display the mouse pointer?

There have been no hardware changes or software programs added before the dist upgrade.

The machine has 16GB of RAM and has an Nvidia Quadro K4100M video card and an Intel Integrated graphics controller with i915 driver.

I am a terminal novice so happy to try commands to get more info but will need the full command, please.

Hoping someone will be able to help, thanks in advance to anyone with some suggestions.

  • Try using sudo apt-get dist-upgrade instead of sudo apt-get upgrade to make sure you have the newest kernel. You will need to reboot to apply the changes. – mchid Jul 19 at 3:56
  • Hi mchid, Thanks for the reply. I followed your suggestion, seemed to update about 84kb of files, so good to know I have the most up to date now. However all mouse click and keyboard shortcut problems remain unchanged =( Cheers for the tip. – Jana Harewood Jul 19 at 4:57
  • You should run sudo apt dist-upgrade or sudo apt full-upgrade (they both do the same thing) every once and a while in order to get the latest kernel updates. The only time this command usually causes problems is when you have manually installed some proprietary drivers like Nvidia or if you have compiled your own wifi driver. – mchid Jul 21 at 23:51
2

Ok, 4 days later this worked!!!

Force reset of all gnome settings
$ dconf reset -f /org/gnome/

I have lost all my customisations and have some work to do to get things back to how they used to be, but at least I didn't have to do a fresh install and lose all the many programs we have installed and setup over the last year or 2.

I have been slowly re-instating the customisations one by one to see what breaks it. Seems this is the culprit:
Tweaks > Extensions > Workspaces to Dock
So I will likely not be able to use multi-workspaces. Looks like it has broken mouse clicks etc for others too...
https://github.com/passingthru67/workspaces-to-dock/issues/134

  • youve done very well in trying with all that...one suggestion I would make is to use a disk backup program like Clonezilla. my technique is to, where possible, when there is a huge issue, backup the home folder, reinstall the last Clonezilla backup to that partition, then recopy the home folder back. Some time I will put the home folder on another partition. – pierrely Jul 20 at 5:59
  • Hi pierrely, Good suggestion. I have had many issues in the past with distribution upgrades. I did do a full backup of data before I did this upgrade. I have used Clonezilla & Norton Ghost before to take an image of the OS (especially in the windoze days of past), don't know why I didn't this time. Good tip! – Jana Harewood Jul 20 at 7:16
  • @Jane .. I always lapse back into bad habits, and the chances of something going very wrong is in proportion to the backup I have not done that time. I wish Clonezilla would allow for 'logged in' backups, and for individual file restorations the way Acronis True Image used to when I was in Windows land. TimeShift is one to try out some day, though one goes with what one is used to and has proven it's worth many times. github.com/teejee2008/timeshift – pierrely Jul 21 at 6:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.