0

I have installed Maas (region contoller) on a PC (Ubuntu 18.10 - desktop. Same error on 19.04 Desktop). I was able to get the web GUI (http://$API_HOST:5240/MAAS) going and was busy with setting up the Vlan etc. I did not complete the setup (I guess I did not set the VLAn that will provide dhcp).

When I rebooted, the Ubuntu desktop froze upon startup giving a list of messages about maas-server/pyhon errors (Permission denied). A screenshot from the error message is attached.

enter image description here

I was able to determine that Maas is not running anymore:

$ sudo systemctl status maas-dhcpd

maas-dhcpd.service - MAAS instance of ISC DHCP server for IPv4 Loaded: loaded (/lib/systemd/system/maas-dhcpd.service; enabled; vendor prese Active: inactive (dead) Condition: start condition failed at Fri 2019-06-21 12:43:04 SAST; 4s ago └─ ConditionPathExists=/var/lib/maas/dhcpd.conf was not met Docs: man:dhcpd(8)

The command to restart Maas, does not help. ($ sudo systemctl restart maas-dhcpd)

I reinstalled everything on Ubuntu 19.04 Desktop and got the same initial error. Screen froze with the error message provided above. I can get the minimal desktop back with "$ sudo startx" but some of the features (internet browser) will not work. When I use "sudo systemctl restart gdm3" a new Desktop start screen appear, but I cannot login.

However, this time I completed the Maas setup on the Maas GUI. Now I Maas is still running when I reboot.

Here is a link the "/etc/profile" contents: https://shorturl.at/luzS6

Anyone that can propose or point me to a solution?

Hope that helps. Gert Kruger

  • That pixs is unviewable. at 200+% blurry. below that too small letters. Please copy/paste the text into the question. – Rinzwind Jul 18 at 17:57
  • Thanks. Since the screen is frozen, I don't seem able to copy the text. I have look at all the log files (/var/log/ and /var/log/maas/) but don't seem to find it there either. I have added a better picture in the original post above. Thanks for your help! – Gert Kruger Jul 22 at 14:50
  • Please notice ConditionPathExists=/var/lib/maas/dhcpd.conf was not met – Yaron Jul 22 at 14:54
0

I tried to find find the solution to both issues. I hoped the python error wil be resolved when you install ubuntu-server on the desktop system:

$ sudo apt-get install ubuntu-server

I still gave the same Python permission error. Ctrl + Alt + F3 gives you a terminal to login. Then to get the Desktop Gui back:

$ sudo systemctl restart gdm3

Next, I installed Synaptic Package Manager and used it to reinstall Python3 as well as gdm3.

That seemed to have solved the problem.

The second point is actually not an issue. Until you have provided DHCP via a VLAN on the Maas Gui, you will get this error when you run:

$ sudo systemctl status maas-dhcpd

After DHCP was set via Maas, this command gives the green light!

Hope this assists other Maas users! Best wishes Gert Kruger

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.