8

Problem:

Audio over bluetooth is unlistenable due to constant stuttering.

System details:

  • Kubuntu 18.04
  • USB bluetooth dongle (listed in lsusb as: 0b05:17cb ASUSTek Computer, Inc. Broadcom BCM20702A0 Bluetooth)
  • Computer connected to internet by Ethernet (no wifi)
  • packages up to date
  • 2 x Intel Xeon 5150 processors
  • about 8GB of RAM

Things that aren't the problem:

  • the problem is not interference (the headphones work fine on my phone / Windows computer in the same location)
  • audio in general (audio over headphone jack is fine)
  • probably not a connection issue (the headphones connect quickly, and I've disabled bluetooth on my phone and Windows laptop while testing)

I've tried:

Nothing has worked. It's probably 50% better now with threadirqs and rtirq-init, but it's still unusable...

Any pointers for more things to try would be much appreciated.

4
  • 2
    Nice to know stuttering audio is just a years-long, persistent issue on Linux (judging by the number of stuttering audio questiosn) with no solution (judging by the lack of solutions)... I love Linux and Kubuntu especially, but damn, why is audio so crummy? Commented Jul 26, 2019 at 0:53
  • just upgraded from 18.04 to 19.04 (fresh install, everything up to date) and now I have the exact same problem. It's completely unusable with constant stuttering or even pausing for seconds. With 18.04 it worked fine (except that I always had to connect it twice, but whatever). I'll let you know if I find a solution.
    – Prinzhorn
    Commented Aug 14, 2019 at 18:24
  • I ran pulseaudio -k && sudo alsa force-reload and rebooted. I've been listening to music for 10 minutes no problem so far, fingers crossed. Maybe pulseaudio/alsa are a little shy when you connect a device for the very first time. Not sure if it's of any use for you.
    – Prinzhorn
    Commented Aug 14, 2019 at 18:43
  • "why is audio so crummy?" Back around 1997, the audio setup help file included a bit of attitude including a statement "if you must hear biff bark..." indicating to me that even the people who were helping to make Linux audio possible didn't consider it a high, or worthy, priority.
    – MangoCat
    Commented Feb 29, 2020 at 20:22

1 Answer 1

7

was having the same problem. Also tried upgrade to 19 as well as bluez.

What finally worked for me was to restart the service:

sudo service bluetooth restart

the first time I tried it, it didn't restart cleanly, but it worked on the second try. Listening to music now for over an hour and no stuttering.

Not sure how often this will need to be done, but I can imagine putting it in crontab if no one patches it for awhile.

3
  • This worked for me for now. How long did this work for you? Did you have to set up the crontab?
    – Relevance
    Commented Dec 17, 2021 at 8:22
  • 1
    I'm now running Ubuntu 20.04.3 LTS and I no longer have to do this on restart. I expect it was patched somewhere.
    – Ru887321
    Commented Dec 19, 2021 at 22:10
  • Thanks for the reply.
    – Relevance
    Commented Dec 28, 2021 at 8:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .