2

Not a repost, I've checked carefully similar questions and none of them describe what I'm actually experiencing.

The problem: every time I boot into windows I'm no more able to boot into Ubuntu because of a series of ACPI exceptions regarding V0P, V1P, V2P (kernel modules?), I couldn't take a screenshot or copy and paste but the error was along the line:

dspkginit-381 couldn't find/resolve named package element: V2P

The machine: MSI GL62M-7REX
OS: Ubuntu 16.04 in dual boot with Windows 10

What I tried:

  • Some were saying it was a problem of the bios not being update. It is not, after updating the bios nothing changed.
  • Some were saying it was a harmless bug and avoiding acpi would fix the problem. Not working either, acpi=off, acpi=strict in the grub file (as suggested somewhere for - apparently - similar problems) hasn't fix the problem.
  • Some were saying it was windows messing with grub. It is clearly windows messing up with something but not the grub, I repaired it, updated it, whatever... Not working. I point out that the grub still works perfectly - as far as I know - not showing any strange behavior.
  • I tried to fix the bios / grub from windows using bcdedit as explained here and somewhere else as well, but isn't working.
  • Some were saying it was a GPU related problem, and it actually may be BUT before using windows (and after - I'll explain this in a moment) Ubuntu works perfectly with no issue.

Important Notes:

  • I'm having this problem for months but I've actually always been able to get back to Ubuntu (until now, that I'm stuck in windows). How? I DON'T KNOW. I just tried various times booting back and forth from Ubuntu to windows touching things but without actually changing anything and apparently totally randomly Ubuntu starts to work again.
  • This is not an installation related problem, meaning that it didn't come right after installation, I've been using Ubuntu for years and never had such an issue before - maybe - some updates from windows (I cannot say when exactly the mess began because I rarely use windows, but I can't wipe it out because however I need it).
  • GPU gave me a lot of problems when first installing Ubuntu (GTX-1050Ti) but I managed to resolve all of them and it worked fine for while, then Nvidia updated the drivers and messed everything up. Since then I have never been able to see the GPU from Ubuntu again BUT the system has always worked fine (using internal GPU) and the GPU kept (and keeps) working in windows.

I hope everything is clear, please head me somewhere, I'm struggling.

Edit: I am now writing from Ubuntu without literally doing anything, so my guess is that after installing updates windows keeps doing something in the background fixing the mess he creates.
Is that possible? What operations are transparently conducted by windows after updates procedures that may cause everything I described?

0

It seems I found the issue thanks to the help I received from reddit:

Fast Boot.
But be careful, I thought I was ok about fast boot because it was (at least once) a BIOS option, whereas I recently found out that there's a software switch in windows settings. This is how to disable it.

The problem was fast boot kept "active" some data caching about an NTFS partition I shared between Ubuntu and Windows, preventing the former to boot completely.

Now everything is working fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.