0

I'm not an experienced user, so please bear with me. I've been trying to install Kompozer from two different sources, but none of them worked.

First, I downloaded a .deb file from here (https://download.cnet.com/KompoZer-for-Debian-and-Ubuntu/3000-10247_4-75219243.html), but my package installer was unable to install it. The dpkg command didn't work neither. When I run sudo dpkg -i /home/jesus/Downloads/kompozer_0.8_b3.dfsg.1-0.1ubuntu2_amd64.deb, I get the following:

(Reading database ... 255283 files and directories currently installed.)
Preparing to unpack .../kompozer_0.8_b3.dfsg.1-0.1ubuntu2_amd64.deb ...
Unpacking kompozer (1:0.8~b3.dfsg.1-0.1ubuntu2) over (1:0.8~b3.dfsg.1-0.1ubuntu2) ...
dpkg: dependency problems prevent configuration of kompozer:
 kompozer depends on libpng12-0 (>= 1.2.13-4); however:
  Package libpng12-0:amd64 is not installed.

dpkg: error processing package kompozer (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db (2.8.5-2) ...
Processing triggers for gnome-menus (3.32.0-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.23-4ubuntu1) ...
Processing triggers for bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.60ubuntu1) ...
Errors were encountered while processing:
 kompozer

I tried to install the libpng12-0 from (https://packages.ubuntu.com/xenial/amd64/libpng12-0/download); However, I got another problem:

(Reading database ... 255283 files and directories currently installed.)
Preparing to unpack .../libpng12-0_1.2.54-1ubuntu1.1_amd64.deb ...
Unpacking libpng12-0:amd64 (1.2.54-1ubuntu1.1) ...
dpkg: error processing archive /home/jesus/Downloads/libpng12-0_1.2.54-1ubuntu1.1_amd64.deb (--install):
 unable to install new version of '/lib/x86_64-linux-gnu/libpng12.so.0': No such file or directory
Processing triggers for libc-bin (2.29-0ubuntu2) ...
Errors were encountered while processing:
 /home/jesus/Downloads/libpng12-0_1.2.54-1ubuntu1.1_amd64.deb

Then, I tried this PPA (https://launchpad.net/~giuseppe-iuculano/+archive/ubuntu/ppa), but it also fails. When I type "sudo apt-get install kompozer", I get the following:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
kompozer is already the newest version (1:0.8~b3.dfsg.1-0.1ubuntu2).
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 kompozer : Depends: libpng12-0 (>= 1.2.13-4) but it is not installable
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

I have seen a few answers on this site to people having similar problems with the installation of Kompozer, but they didn't work for me.

Any ideas? Thanks.

0

When you installing package with dpkg, it just installs this package, when all requirement are met. It does not look around, how to install those dependencies you may need for particular package. So one way (hard) is to make sure which packages your wanted package additionally need and download them an install them first.

Easier way is to do like you did and afterwards run one command (as suggested in your output, too):

sudo apt --fix-broken install 

Anyway, your output also says:

kompozer is already the newest version (1:0.8~b3.dfsg.1-0.1ubuntu2)

I have no idea, is this really newest version (and version you need), but it seems somehow already installed. If you tried from multiple sources, there may be something still wrong, running command from above should fix this (most times).

Edit

You stucked and fix-broken won't help. So, my solution would be to remove kompozer from system completely, like:

sudo apt purge kompozer

and then try to install it already from repo:

sudo apt install kompozer

Edit2

After closer look to Kompozer I must tell: this software is so old, that it may be too hard to ran on such a new system, it depends on libraries from Ubuntu 12.04 or older. Maybe it is simpler to run it with older Ubuntu?

  • When I run sudo apt --fix-broken install, I get the following: pastebin.com/HKtDKXYU and it looks pretty much like it got removed... – Jesús Lencina Jul 16 '19 at 23:15
  • Ok, did not notice it, sorry. So you have mixed two paths, from file and from repo together. I try to address your situation in my answer. – wk. Jul 16 '19 at 23:18
  • After the purge command, when I type "sudo apt install kompozer" I get this output: pastebin.com/7hZYuVTs I tried re-adding the PPA and trying again, but didn't work – Jesús Lencina Jul 16 '19 at 23:27
  • @JesúsLencina With command ls -la /etc/apt/sources.list.d/ you can list which additional repos (PPAs) you have besides official. Do you see a file there, which may refer to needed PPA? – wk. Jul 16 '19 at 23:32
  • The word Giuseppe (which is the name of the PPA) appears in two lines... All the sources look to appear twice though... Here's a picture i.imgur.com/gj0tYDi.png – Jesús Lencina Jul 16 '19 at 23:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.