13

What is the standard way to turn numlock on by default on startup on lubuntu 10.04?

Lubuntu installs LXDE. I saw some aother solutions for other flavours, but maybe there is a special setting for the lubuntu flavour.

I tried already numlock=0 and numlock=1 in /etc/lxdm/lxdm.conf , but numlock stays off on the next boot.

All other operating systems, also other ubuntu systems, do have numlock turned on on the same machine after booting.

I installed numlockx, and it can change the value, but is this the standard lubuntu way to go? If so, what is the standard place in the lubuntu startup sequene to insert 'numlockx on', how do I set this up correctly?

I also looked at the included lxde keyboard configuration system gui tool, but there are only few options, numlock default not among them.

(Please before you mark this as duplicate consider if it really fits, I could not find this answered in this way. I am interestd to know the standard way for lubuntu (and not kubuntu or gnome) in detail.)


There is also an explanation of the lxdm config file here, but it does not really explain what "lxde numlock suport" means (how could a gui not support numlock?) and what the settings 0 and 1 mean:

http://manpages.ubuntu.com/manpages/lucid/man1/lxdm.1.html


If there is no other LXDE or lubuntu standard way to do it, I am planning to use numlockx and add this line:

/usr/bin/numlockx on

at the beginning of either

/etc/X11/xinit/xinitrc

or

~/.xinitrc

following the instructions found here:

http://www.cyberciti.biz/faq/how-to-linux-turn-on-num-lock-on-gnome-startup/

  • Isn't there a BIOS configuration for numlock state on startup? Most computers has it. – yossile Mar 25 '12 at 12:35
  • This wold be the best but unfortunateley this machine does not have such an option in the BIOS, so I need a linux solution. – mit Mar 25 '12 at 14:17
14

Have you tried editing /etc/xdg/lubuntu/lxdm/lxdm.conf instead?

Uncomment # numlock=0 and make it numlock=1

Worked for me :)

More Info:

You need to have "admin" permission (a.k.a. root, or sudo) to make the change, so use...

Works for Lubuntu 16.04:

Go to your "Start button" > System Tools > LXTerminal

In terminal, type: sudo pcmanfm

After entering your password a new folder window will open, it gives you admin/root permission. Click "Up" arrow twice to find /etc folder.

Then navigate to /etc/xdg/lubuntu/lxdm/lxdm.conf

Right-click on lxdm.conf and choose Leafpad to edit and make changes.

To make changes, replace # numlock=0 with numlock=1

Now click Save, and close Leafpad. Done.

You no longer have admin/root permission after window is closed. To "Uncomment" simply means removing # symbol, which will "activate" the command.

  • Thank you teracow. I have abandoned "lubuntu" for other reasons, so I cannot check, but your answer will help other people in the future. – mit May 2 '12 at 12:16
  • 4
    update: this solution worked for lubuntu upto 11.10 Oneiric. However, I've just upgraded to 12.04 Precise and it does not work anymore. Oh well. ;) – teracow May 5 '12 at 20:32
  • 2
    another update: so, now I'm using numlockx - doesn't need to be configured, just installed. – teracow May 6 '12 at 0:18
  • teracow's setting are the same that currently work for me without using numlockx. I'm currently using 12.04 with the setting of numlock=1 in both /etc/xdg/lubuntu/lxdm/lxdm.conf and /etc/lxdm/lxdm.conf – iyrin Jul 24 '13 at 23:04
  • 1
    had no influence in case of Lubuntu 16.04 - not working – linolino Feb 20 '18 at 16:23
6

bootup numlock for Lubuntu 14.04.1 steps:

  • dl numlockx via synaptic
  • then edit the file /usr/share/lightdm/lightdm.conf.d/50-greeter-wrapper.conf.

Use e.g. this command in a terminal:

sudo gedit /usr/share/lightdm/lightdm.conf.d/50-greeter-wrapper.conf

add this line:

greeter-setup-script=/usr/bin/numlockx on 
  • save file and reboot your system
  • this change might be better made in /etc/lightdm/lightdm.conf – Riot Aug 3 '16 at 14:38
  • Am on lubuntu 16.04 working as @Moi (not working for me as @Riot). But NUM is only on at logon prompt, as soon logged in it is off again :-/ – linolino Feb 21 '18 at 18:43
4

This works for me:

sudo su -
apt-get install numlockx
echo "/usr/bin/numlockx on" >> /etc/xdg/lxsession/Lubuntu/autostart

Best regards!

3

That works for me:

sudo apt-get install numlockx

then restart the PC.

That's all!

  • works for me in Lubuntu 18.04 – user1053510 Sep 4 '18 at 16:46

protected by Eric Carvalho Jul 26 '15 at 14:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.