For ultra specific reasons, I created a dual boot Ubuntu Mate 18.10 / Windows 10 and the last "bug" I need to fix is the Intel wifi driver for my card ( Intel Corporation Wireless-AC 9560 [Jefferson Peak] ) on my msi GF63 8RC.

The problem is if my wifi card works everytime on the Windows, on Linux it seems not to be the case.

For example, when it works, it got this by dmesg :

[   22.634376] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
[   22.815281] iwlwifi 0000:00:14.3: loaded firmware version 38.c0e03d94.0 op_mode iwlmvm
[   24.464530] iwlwifi 0000:00:14.3: Detected Intel(R) Dual Band Wireless AC 9462, REV=0x318
[   24.515472] iwlwifi 0000:00:14.3: base HW address: 7c:2a:31:a6:80:24
[   24.972323] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[   25.072145] iwlwifi 0000:00:14.3 wlo1: renamed from wlan0
[   45.872215] iwlwifi 0000:00:14.3: Conflict between TLV & NVM regarding enabling LAR (TLV = enabled NVM =disabled)

but when it didn't work :

[   16.387791] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
[   16.464190] iwlwifi: probe of 0000:00:14.3 failed with error -110

The full wireless-info when everything works : https://paste.ubuntu.com/p/h3JGcwstPS/

Thanks for your help :)

PS: My /etc/modprobe.d/iwlwifi.conf if needed :

# /etc/modprobe.d/iwlwifi.conf
# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
# microcode file installed on the system.  When removing iwlwifi, first
# remove the iwl?vm module and then iwlwifi.
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211
  • In what situations it doesn't work? Is it perhaps when you reboot from Windows to Ubuntu?
    – user880592
    Jul 16, 2019 at 18:03
  • After I finish what I have to do on each OS, I shutdown it. The thing is I suspect that Windows somehow blocks the iwlwifi but since I didn't have a man page to find out what could means this -110 error code ....
    – jy95
    Jul 16, 2019 at 18:08
  • Ubuntu 18.10 is near EOL. Consider to upgrade it to 19.04.
    – N0rbert
    Jul 16, 2019 at 21:12
  • thanks for the reminder: honestly I sometimes prefer a better tested version that a new one directly ( with exceptions of course like python ). As my nvidia drivers work, I got no real reasons to do that in this dual bool test (I moved yesterday from 18.04 to 18.10 as the wifi driver requires a kernel >= 4.15 from what I read on some forums )
    – jy95
    Jul 16, 2019 at 21:34
  • Reviewers: Please don't flag old questions as EOL Jul 19, 2019 at 20:16

1 Answer 1


I suggest that you try a driver parameter:

sudo modprobe -r iwlwifi && sudo modprobe iwlwifi lar_disable=Y

If it seems to solve the issue, then I suggest that you make it permanent:

sudo -i
echo "options iwlwifi lar_disable=Y"  >>  /etc/modprobe.d/iwlwifi.conf

You should be all set.

  • Thanks, first time I ever see this option in modprobe command ... I will try your commands and say if it changes something . What do you think about Wi-Fi / Bluetooth coexistence ? wiki.debian.org/iwlwifi#Troubleshooting and wireless.wiki.kernel.org/en/users/Drivers/…
    – jy95
    Jul 16, 2019 at 20:05
  • I dount that BT coexist is relevant to the error in your dmesg. You aren't, as far as I see, having bluetooth troubles.
    – chili555
    Jul 16, 2019 at 20:32
  • In case of, I disabled my BT ... I included my default iwlwifi.conf iif you need that
    – jy95
    Jul 16, 2019 at 20:36
  • ( I will answer you tomorrow : it seems hard to reproduce on my wifi networks (2.4Ghz, 5Ghz) except on this 'eduroam' in university )
    – jy95
    Jul 16, 2019 at 20:59
  • Please see my posts about eduroam: askubuntu.com/questions/841620/…
    – chili555
    Jul 16, 2019 at 21:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.