I have tried to find some solution online, but none has turned up so far, so I ask here: I have a paid VPN connection using VYPR-VPN which relies on the OpenVPN client. After updating to 18.10, I find myself in quite a strange situation:

  • The new network manager widget opens a terminal based program to configure my connections, but there is no VPN option (or is "VLAN" what I need? If yes, it seems quite complicated?).
  • In preferences (main menu) I find a network connection app which actually works as desired (like the ones in the previous Lubuntu versions), but whatever I enter there seems to have no influence on the network widget down in the launch bar, and these connections are not offered to me anywhere.

Since I pay for my VPN service, I'd really like to USE it. Does anybody have any idea how to configure my VPN without first having to do a PhD in Linux System Administration? Does it work better in 19.XX? Thanks in advance!

  • 1
    Have you tried following their instructions in support.goldenfrog.com/hc/en-us/articles/… ? Sometimes a VPN server may go down. Try changing to a different server. Note (L)Ubuntu 18.10 will reach the end of its life on July 18, 2019. You may want to upgrade to a supported version before that. After that date, all the repositories will be moved to archives. That means you won't get updates, and install apps. Also questions about 18.10 will be off-topic in this site after that date.
    – user68186
    Jul 16, 2019 at 19:42
  • 1
    That's two days from now {/hint}.
    – K7AAY
    Jul 16, 2019 at 20:14
  • Honestly, I'd love to stick with 14.something. But then I could not even install support for NTFS, and I needed that. Offtopic? That sounds really cruel. Why change a winning system every now and then? Jul 16, 2019 at 22:30
  • 18.10 it's not LTS version if you don't want to change OS every time and then there's no need to upgrade to temporary releases, Ubuntu 18.04 and based alike is a long term distro and will be supported until 2023. When you did update to 18.10 something might have went wrong in system configuration. Did you try to remove and reinstall VPN related packages on your distro? You can remove configuration files in your Home directory and perform a clean install of the VPN service that you are using.
    – JoKeR
    Jul 16, 2019 at 22:47
  • 18.04 has frequently rebootet (without any warning), and after approx a week of discriminating experiments I am absolutely sure that it has in fact been the OS. So I had to go to 18.10, and it has been a complete, clean reinstall, including a new partition table and complete reformatting. All the config files are therefore 18.10 and new. But no, I have not tried to remove and reinstall yet. Perhaps I'll try that one unless I find another solution, so thanks for the idea. Jul 16, 2019 at 23:04

2 Answers 2


The problem has somehow solved itself, I think either through logout or through a reboot. So for all out there who ever have a similar problem like this one, perhaps a reboot is sufficient.

Detail to be noted: I have defined the connection through
Menu > Preferences > Network connections

and not through the console based application that opens from the network widget. This connection now appears as an additional tun0, not as vypr, as used to in 18.04. VyprVPN also appears when I click the widget, but not as the active connection. Left click -> information also shows all three connections.

I am not quite sure why this is so, but at least the VPN works now, so the problem is solved.


I have now two network widgets in the launch bar. The new one I got with the installation of the system, and the one I am used to from previous versions. That one offers all the comfort I am used to.

  • I am voting to close this question as the problem seemingly went away on its own (with a reboot).
    – user68186
    Jul 17, 2019 at 15:38
  • Yes, I agree. Do I have to do that? Sorry for that stupid question, but I am quite a newbie. Jul 17, 2019 at 16:56
  • It is best if you just delete the question. Otherwise it will take few more reviews and votes by others with enough reputation to close the question. If you delete the question it will save the time for the reviewers.
    – user68186
    Jul 17, 2019 at 17:23
  • Why should I delete a question that might be useful for others? If I had seen a question like this, answered with "it worked for me after reboot", I would have done exactly that much much earlier. And then it might have worked or might not have worked, and in the latter case I could have added a comment that it didn't work out for me. Furthermore, there is some more information to be found in the answers and comments. I don't think this result to be entirely useless. Jul 17, 2019 at 18:21

https://www.vyprvpn.com/vpn-apps shows no client app for Ubuntu or even Linux, so I'd suggest you talk to your commercial VPN provider about
a) what other client you could use
b) what version they recommend for 18.10, 19.04, et al., and
c) how to configure it for their service.

  • 1
    But they do. It worked well up to lubuntu 18.04. I could even install it for 18.10. I can even configure it as usual, through the menu. I only need this connection to appear in the network manager applet, as it used to be in the previous version. Jul 16, 2019 at 18:49
  • My job site has goldenfrog.com firewalled, so I cannot see that.
    – K7AAY
    Jul 16, 2019 at 20:13
  • Oh, I have one... on MY laptop and phone. Those never get in the front door, much less past Security. And {topicdrift} you have two days until 18.10 is no longer supported, so it's time for 19.04 or 18.04 LTS. {/topicdrift}
    – K7AAY
    Jul 16, 2019 at 20:27
  • Thanks a lot! I found out that both are already installed. How will I invoke them? BTW I use it privately. No employer involved. ;-) Jul 16, 2019 at 22:11
  • And thanks for the link. Already did all that (which is why I had everything installed already). Nevertheless - I can configure from the menu (preferences -> network connections), but after doing so, the network management widget down there does not even offer a VPN - and trying to configure a connection from there leads to that terminal based program that has nothing to do with what I found in the menu. So somehow I think I got the wrong widget in the launch bar, or something similar. Jul 16, 2019 at 22:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.