0

I have a fresh install of Ubuntu 18 on a server. I setup a static IP with netplan using networkd as renderer. On my network, I have 4 DNS Server, here the netplan config file:

network:
    version: 2
    renderer: networkd
    ethernets:
        ens160:
            dhcp4: no
            addresses: [192.X.Y.34/24]
            gateway4: 192.X.Y.254
            nameservers:
                addresses: [192.X.Y.10,192.X.Y.11,A.B.C.10,A.B.C.11]

I add a A record for xxxx.yyyyyy.com (who pointed to A.B.C.21) on my DNS servers (It's local servers) When I run the command nslookup xxxx.yyyyyy.com, I got the following answer.

Server:         127.0.0.53
Address:        127.0.0.53#53

Non-authoritative answer:
Name:   xxxx.yyyyyy.com
Address: 192.X.Y.21

So why it's a Non-authoritative answer ? It's on the same network.
Should I add a search in the netplan config with the domain name ?

Btw when i run systemd-resolve --status, i got the good list of DNS Server

...
         DNS Servers: 192.X.Y.10
                      192.X.Y.11
                      A.B.C.10
                      A.B.C.11

I don't have Network Managerinstalled on the server.

If anyone have an idea to solve this problem :)

Thanks,

  • 1
    perhaps a router or other device is what provided you the answer here. I don't think the fact this is happening on an ubuntu really makes this general website setup question on topic here but whatever, I didn't flag this. – tatsu Jul 16 at 15:25
0

"Non-authoritative answer" is expected output when the DNS server that returned the result to you is not directly the authoritative nameserver for that domain.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.