3

For the command:

apt-cache show google-chrome-stable

I get:

Package: google-chrome-stable
Version: 7.0.517.44-r64615
Architecture: i386
Maintainer: Chrome Linux Team <chrome-linux-packager@google.com>
Installed-Size: 76076
Pre-Depends: dpkg (>= 1.14.0)
Depends: ca-certificates, libasound2, libatk1.0-0 (>= 1.13.2), libbz2-1.0, libc6 (>= 2.6-1), libcairo2 (>= 1.4.0), libfontconfig1 (>= 2.4.0), libfreetype6 (>= 2.3.5), libgcc1 (>= 1:4.2.1), libgconf2-4, libglib2.0-0 (>= 2.14.0), libgtk2.0-0 (>= 2.12.0), libjpeg62, libnspr4-0d (>= 4.7.1), libnss3-1d (>= 3.12.3), libpango1.0-0 (>= 1.18.3), libpng12-0, libstdc++6 (>= 4.2.1), libxslt1.1, libxss1, lsb-base (>= 3.2), wget, xdg-utils (>= 1.0.1), zlib1g (>= 1:1.2.3.3.dfsg-1)
Conflicts: google-chrome
Replaces: google-chrome
Provides: google-chrome
Priority: optional
Section: net
Filename: pool/main/g/google-chrome-stable/google-chrome-stable_7.0.517.44-r64615_i386.deb
Size: 21896322
SHA1: 2a09d457180a77a6d1472f24562feb43c2184cf5
MD5sum: eff030c9ebee87eb3abff1ce95f65796
Description: The web browser from Google
 Google Chrome is a browser that combines a minimal design with sophisticated technology to make the web faster, safer, and easier.

Package: google-chrome-stable
Status: install ok unpacked
Priority: optional
Section: web
Installed-Size: 108380
Maintainer: Chrome Linux Team <chromium-dev@chromium.org>
Architecture: i386
Version: 17.0.963.83-r127885
Replaces: google-chrome
Provides: google-chrome, www-browser
Depends: libasound2 (>> 1.0.22), libbz2-1.0, libc6 (>= 2.11), libcairo2 (>= 1.6.0), libcups2 (>= 1.4.0), libdbus-1-3 (>= 1.2.14), libexpat1 (>= 1.95.8), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.3.9), libgcc1 (>= 1:4.1.1), libgconf2-4 (>= 2.27.0), libgcrypt11 (>= 1.4.2), libglib2.0-0 (>= 2.18.0), libgtk2.0-0 (>= 2.18.0), libnspr4-0d (>= 4.7.3-0ubuntu1~) | libnspr4 (>= 4.8.7-0ubuntu1), libnss3-1d (>= 3.12.3), libpango1.0-0 (>= 1.20.0), libpng12-0 (>= 1.2.13-4), libstdc++6 (>= 4.4.0), libx11-6 (>= 0), libxext6 (>= 0), libxfixes3 (>= 1:4.0.1), libxrender1, libxss1, zlib1g (>= 1:1.2.3.3.dfsg), ca-certificates, libcurl3, libatk1.0-0 (>= 1.30.0), lsb-base (>= 3.2), xdg-utils (>= 1.0.2), wget
Pre-Depends: dpkg (>= 1.14.0)
Conflicts: google-chrome
Description: The web browser from Google
 Google Chrome is a browser that combines a minimal design with sophisticated technology to make the web faster, safer, and easier.
3
  • What happens if you run sudo apt-get install google-chrome-stable? What you have here simply shows that apt can find it in the repository. – Shauna Dec 3 '12 at 16:25
  • As the first commenter has implied, there doesn't seem to be an actual attempt to install google-chrome. It's not clear if NeoTM just doesn't know how to install stuff with apt, or some other issue. And the external edits to the question have simply aggravated the situation. Now you know why I modded it down.. yw – user1974 Oct 16 '13 at 21:08
  • It seems it's literally installed. – Star OS Dec 15 '15 at 10:07
14

Download the .deb file directly from the Google Chrome website and install it (double-click on it).
This will also add the repository for stable updates in the future.

1

Use the Ubuntu Software Center to install Chromium. Just search for "Chromium Web Browser" and it will look like the Chrome icon in shades of blue. It is made by Google, but Chrome is Chromium re-branded.

but Ubuntu Software Center not contain the latest update

3
  • 2
    Chromium is not Chrome, it's an open source browser that is the base for Chrome. Chrome add features over Chromium like built-in flash support and some other things – Javier Rivera Mar 26 '12 at 15:51
  • @JavierRivera the main other things are automatic updating, which is negated by the repositories anyways, and the branding. The web app store still works perfectly, for instance. However, you are definitely correct. – Andrew Wonnacott Mar 26 '12 at 17:15
  • There a couple of other things: Error reporting, spyware, sorry I mean sending user metric stats to Google, and the built-in Pdf reader. – Javier Rivera Mar 26 '12 at 17:30
1

If you want to use Google Chrome, then download from their official webpage.

My advice, use the Chromium browser, it is 100% compatible with Chrome (in my case I sync between Google Chrome on Win/Mac with my Chromium in my Ubuntu machine, and works smooooth).

sudo apt-get install chromium-browser
1
  • 1
    A tangent note regarding Chrome vs Chromium - while they may be compatible, in my experience Chromium's version of Webkit is usually a version or three behind Chrome. This is important if you do any kind of work with HTML/CSS, because Chromium may not have some of the more cutting edge features that the most recent version of Chrome has. – Shauna Dec 3 '12 at 16:23
0

As stated, you can download directly from the Google Chrome website. Google is very good at offering packages for Linux of all flavors, and you will find a 32-bit version just for Ubuntu. Once you download this package you will find it stored in your Home/downloads folder. You should now be able to run this download which will automatically open Ubuntu Software Center; it will take you to the Google Chrome Package page. There should be an install button on the page, once you click it you will be prompted for your password.

Please note, this process can lag up and patience is the best practice.

  • If you are looking to make Google Chrome your primary browser, you will be prompted to do so upon opening the program for the first time!
  • Don't forget (for good practice) to remove unused programs! If you not using Firefox you can open up terminal by pressing Ctrl+Alt+T and typing in the terminal window that opens up sudo apt-get purge firefox*

Good luck!

0

You can try downloading the .deb file from Chrome official site and then simply install it with double click. If you face a problem.. then you can get help from here:

http://www.computerandyou.net/2011/10/how-to-install-google-chrome-in-ubuntu-11-10/

0

As other answerers have mentioned, you can download the .deb file from the Chrome site.

BUT: Make sure you have the right architecture. If you have 32-bit Ubuntu, you want i386; for 64-bit you want amd64.

-2

Use the below command in terminal to install the chromium(variant of chrome) browser Ubuntu

sudo apt-get install chromium-browser

Not the answer you're looking for? Browse other questions tagged or ask your own question.