1

The audio is stuttering/crackling whenever played in external speakers/headphone or the laptop's speaker.

I have tried several solutions to no avail, and different combinations of them:

  • https://unix.stackexchange.com/a/136591

    • Changing default-sample-rate = 42100default-sample-rate = 48000 at /etc/pulse/daemon.conf.

    • Changing load-module module-udev-detectload-module module-udev-detect tsched=0.

      This has significantly reduced the amount of noise and slowness of the music but it is not perfect.

  • https://askubuntu.com/a/1067759: pulseaudio -k.

  • https://askubuntu.com/a/1135589: Add options snd-hda-intel power_save=0 power_save_controller=N to /etc/modprobe.d/alsa-base.conf.

  • Audio stuttering on 18.04: Quoting:

    • add options snd-hda-intel position_fix=1 to /etc/modprobe.d/alsa-base.conf
    • edit to load-module module-udev-detect tsched=1 in /etc/pulse/default.pa
    • add resample-method = src-sinc-best-quality in /etc/pulse/daemon.conf

    Points to other sources as well.

I have also tried:

pulseaudio -k && sudo alsa force-reload

Reboot.


Other solutions which I have not tried because there is no such an option for me:


I have recently upgraded from Lubuntu 16.04 and it worked perfectly. I have a Lubuntu 18.04:

$ uname -a
Linux abcde 4.15.0-54-generic #58-Ubuntu SMP Mon Jun 24 10:55:24 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
  • 1
    Please update the question with information on your soundcard. lspci -nnk and/or pacmd info should be useful here. It would be good to know the card name, the PCI id, the kernel modules available, and the module used. Also, do you have the same problem if you boot the 18.04 live system? – wxl Jul 16 at 17:29
  • hey @wxl thanks for your consideration. In the end I found a workaround... – fmv1992 Jul 17 at 22:19
0

So after many exhaustive attempts the issue is solved.

The cases and combinations tried are so varied that I cannot determined what did it.

Possibly a combination of the solutions above. If I had to guess what cracked it was uninstalling/purging pulseaudio (leaving the alsa modules) and then rebooting. This certainly solved the issue. Then to my astonishment reinstalling pulseaudio left me with a full-working audio again (pulseaudio is very convenient to chose which output source to use).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.