2

I'm not exactly a newb, but I am when it comes to troubleshooting. I was attempting to get RDP from my Win 10 box to Ubuntu working so I followed these instructions

I did section 1 for Ubuntu 18.04 and followed everything even the ufw portion. Suddenly my computer froze (or at least I thought it did) and so I held the power button and rebooted. Now the keyboard and touchpad on my laptop don't work anymore when the login screen comes up. I can tell it isn't frozen because the time still increments and the screen fades if I wait long enough.

I figured out how to bypass the GUI and get into root by holding shift when the laptop is booting, so I disabled ufw and xrdp, deleted the file I had created, etc. But when I reboot, I still get nothing. I can ssh from my Windows machine but I have no idea what I can do to troubleshoot the issue. I've tried plugging in usb keyboards and mice, but they don't work either.

Any ideas?

1

I noticed there was a related question in the sidebar, so I checked it out and the solution there fixed my issue.

I ran sudo apt install xserver-xorg-input-all and now I can use my mouse and keyboard again.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.