1

I am using Ubuntu 16.04, and for some unknown reason I am not able to open a terminal with CTRL + ALT + T. When I press these keys, nothing happens.

I also tried to start a terminal from Dash, but again nothing happens.

I never had a problem opening a terminal, opened it hundreds of times before with CTRL + ALT + T.

Luckily, I am able to open a terminal by using right-click and choosing "open Terminal". But why can't I open a terminal with CTRL+ALT+T anymore?

The Shortcut is still there (Settings -> Keyboard -> Shortcuts).

6
  • E: Package 'x-terminal-emulator' has no installation candidate ;-)
    – Alex
    Jul 15 '19 at 5:28
  • I have not installed any special terminal, I am using the default terminal I guess. Seems to be gnome-terminal
    – Alex
    Jul 15 '19 at 5:37
  • Yes tried that, no affect. CTRL-ALT-T and Dash still does not work. Maybe there is a date limitation hardcoded somewhere
    – Alex
    Jul 15 '19 at 6:13
  • Alt-F2: I get an application (looks like a map, not the standard terminal icon), clicking on it does nothing. Re-adding the shortcut: No effect
    – Alex
    Jul 15 '19 at 6:38
  • Let us continue this discussion in chat.
    – Alex
    Jul 15 '19 at 6:44
0

1. Install / Reinstall Gnome Terminal

First we have to determine what the default terminal command is, so let's see what terminal(s) we have installed:

$ apt list --installed |grep -i terminal

On default 16.04 you should have gnome-terminal installed. If it is not installed, install it:

$ sudo apt install gnome-terminal

If it is installed, purge and reinstall it:

$ sudo apt purge gnome-terminal 
$ sudo apt autoremove
$ sudo apt autoclean
$ sudo apt install gnome-terminal

Now let's make sure it's set properly:

sudo update-alternatives --config x-terminal-emulator 

Which should return something like this:

There are 5 choices for the alternative x-terminal-emulator (providing /usr/bin/x-terminal-emulator).

  Selection    Path                             Priority   Status
------------------------------------------------------------
* 0            /usr/bin/gnome-terminal.wrapper   40        auto mode
  1            /usr/bin/gnome-terminal.wrapper   40        manual mode
  2            /usr/bin/koi8rxterm               20        manual mode
  3            /usr/bin/lxterm                   30        manual mode
  4            /usr/bin/uxterm                   20        manual mode
  5            /usr/bin/xterm                    20        manual mode

Press <enter> to keep the current choice[*], or type selection number: 

It should be set to the first entry (0), if not set it to 0.

Confirm that your gnome-terminal.wrapper works by running it:

$ gnome-terminal.wrapper

If your terminal wrapper is broken, let me know and I will post a copy of mine or just skip to step 3.

Test your key combo, if it works, you're done! If not read on...

2. Sometimes keyboard shortcuts need to be manually reset.

Go to System Settings -> Keyboard -> Shortcuts -> Launchers and click on the line that says "Launch terminal". Where it once said the key command, it will now say "New accelerator...", press Ctrl+Alt+Shift+T

Keyboard Shortcut Update

Test this new macro (Ctrl+Alt+Shift+T) and see if it works. If it doesn't work, move on to the next step. If it does work, click on the terminal line again and set it back to the original macro: Ctrl+Alt+T.

Now test your shortcut and see if it works. If it still doesn't work, we can make a custom shortcut to launch gnome-terminal.

3. Custom Shortcut to Launch gnome-terminal

Set the default terminal launcher to Ctrl+Alt+Shift+T as described above so it doesn't interfere with our new command.

Now click the plus (+) button at the bottom of the list to add a new item. Call the item "Terminal" with the command /usr/bin/gnome-terminal and click apply.

Add new shortcut

You should now have a menu item that looks like this:

Terminal Disabled

Click on the word disabled and set the shortcut by pressing Ctrl+Alt+T.

Test your shortcut. If it still doesn't work, something must be wrong with your keyboard or keyboard settings. Make sure your language support and text entry settings are correct for your default language and keyboard and try setting an entirely new key combo and see if that works.

0

Are you on a Xfce desktop? If so, go to Settings Manager-->Keyboard>Application Shortcuts> +Add a Terminal shortcut using this file:

/usr/bin/lxterminal

This worked for me in Ubuntu 16.04

~$ inxi -S # to show your desktop version run this cmd at CLI

My version is

System:    Host: <user> Kernel: 5.0.0 x86_64 (64 bit)
           Desktop: Xfce 4.12.3 Distro: Ubuntu 16.04 xenial

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.