1

I have this folder with 25,000 images (around 80MB total) and I want to transfer all of them to a server.

This is the command I am using:

rsync -av -e 'ssh' ./pics/ user@132.456.789.10:~/pics/

The transfer freezes after a couple of files and when I stop the process, I get this error:

rsync error: received SIGINT, SIGTERM, or SIGHUP (code 20) at rsync.c(644) [sender=3.1.2]

I know that it doesn't work because the server location doesn't have the images after freezing.

I tried running the command without the console output -v, but it still freezes.

What might be the problem?

  • If you ssh and do a command which produces 2-3 pages of text, does it work? If not, I would look at MTU sizes. And second question, how do you know it is frozen? – marosg Jul 14 '19 at 18:05
  • @marosg I know it's frozen because I check what was transferred to the server and the files stay the same i.e. nothing is added. I don't know what MTU sizes are, I will check it out. I could use some advice tho. – Ivan Jul 14 '19 at 18:09
  • easiest is to use tracepath command, it will show if mtu changes on the path. Another thing, on target server, have you checked the load? Maybe high wait%? – marosg Jul 15 '19 at 6:51
  • @marosg wtf, the transfer continues if I keep resizing the terminal??? If I stop, the transfer stops. – Ivan Jul 15 '19 at 14:17
  • lol. cannot be, there must be something else going on – marosg Jul 16 '19 at 6:31
0

I experienced this too. Resizing the window to make things work is a real thing :-/ And this fixed things: https://github.com/Microsoft/WSL/issues/2138#issuecomment-393617253

To summarize the solution: Open a new WSL (Ubuntu) window and run this script

while killall -CHLD ssh; do sleep 0.1; done

  • Holy shit, that really fixed it! Weird as fuck. – Ivan Jul 24 '19 at 21:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.