I was hoping someone could help me understand what happened with my Ubuntu server.

I had an issue with it acting odd, I won't go into detail but I restarted the server with this command:

shutdown -r now

When it came back up, I attempted to use screen and was given this error:

No more PTYs. Sorry, could not find a PTY. [screen is terminating]

I found this website which told me this:


You have to change /dev/ptmx file permissions:

# ls -l /dev/ptmx 
crw-r--r-- 1 root root 5, 2 nov 18 23:28 /dev/ptmx
# chmod a+w /dev/ptmx
# ls -l /dev/ptmx 
crw-rw-rw- 1 root root 5, 2 nov 18 23:34 /dev/ptmx

This didn't resolve my issue since I was already at:

crw-rw-rw- 1 root root 5, 2 nov 18 23:34 /dev/ptmx

Same problem.

So I found this post:


So, I did what the answer suggested, which was:

# mount devpts /dev/pts -t devpts -o mode=620

And it worked fine.

Anyone know what happened, why, and what the devpts did to fix it? I'm completely lost on this one.

Thank you!


As far as I can tell, /dev/pts needs to be mounted for screen to work.


I found this when I ran into the same message. Turns out that I had another application (ZTerm) holding a lock on the device. So, as a tip, make sure that no one else is accessing the device!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.