1

I just got a Dell Inspiron 7580 with Windows 10 pre-installed. I wanted to install Ubuntu so I followed the usual instructions:

  • Disabled Secure Boot
  • Disabled Fast Startup

Then I tried to install from a USB stick but the installer could see no disks at all. I then changed from RAID to AHCI. The installation was completed successfully and everything seemed to work fine.

After the installation I wanted to check the pre-existing Windows 10 installation and selected Windows Boot Manager, only to see the infamous INACCESSIBLE_BOOT_DEVICE screen.

Everything is OK in the Ubuntu installation.

A pre-installed recovery tool from Dell reinstalled Windows 10 but still the INACCESSIBLE_BOOT_DEVICE message appears.

1

My problem was apparently different from the suggested question.

The issue I had was that in AHCI mode, Ubuntu booted and worked normally but Windows did not boot at all. Then I switched to RAID and notice that Windows booted and worked normally but Ubuntu did not boot at all.

The problem was that I had switched from RAID to AHCI without safe mode in Windows. When I applied the same switch but in safe mode everything worked fine.

  • Thanks for the tip! For other readers: superuser.com/a/1359471/10136 describes the way to make the change without breaking Windows (by booting into safe mode right after the change). – Nickolay Oct 14 at 0:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.