5

As I was checking the kernel logs I noticed :

kernel: CPU2: Package temperature above threshold, cpu clock throttled (total events = 13430).

I have 4 CPUs and all of them have the same issue. My laptop hardware info :

K46CB (ASUS-NotebookSKU)

CPU info :

  1. Architecture: x86_64

  2. Model name: Intel(R) Core(TM) i7-3537U CPU @ 2.00GHz

I searched the log and found this CPU hardware errors in Ubuntu 17.04 and Stop cpu from overheating, I checked my packages and I have thermald and intel-microcode installed.

I can hear my laptop's fan working, but sometimes it really gets hot and I can feel it through the case.

In Windows-10, although CPU usage gets high, the temperature is usually normal.

Any idea what may have gone wrong? and what can I do to further investigate this issue?

Update

I checked thermald.service status and I found this line :

thermald[879]:sysfs read failed /sys/class/thermal/cooling_device0/cur_state

3

You should see (and possibly subscribe to) this bug report:

There have been numerous posts in Ask Ubuntu about CPU throttling recently:

All these posts say the same thing which happens to me periodically:

~$ journalctl | grep 'cpu clock throttled'
Jun 22 10:55:52 alien kernel: CPU4: Core temperature above threshold, cpu clock throttled (total events = 1)
Jun 22 10:55:52 alien kernel: CPU0: Core temperature above threshold, cpu clock throttled (total events = 1)
Jun 22 10:55:52 alien kernel: CPU6: Package temperature above threshold, cpu clock throttled (total events = 1)
Jun 22 10:55:52 alien kernel: CPU2: Package temperature above threshold, cpu clock throttled (total events = 1)
Jun 22 10:55:52 alien kernel: CPU3: Package temperature above threshold, cpu clock throttled (total events = 1)
Jun 22 10:55:52 alien kernel: CPU7: Package temperature above threshold, cpu clock throttled (total events = 1)
Jun 22 10:55:52 alien kernel: CPU5: Package temperature above threshold, cpu clock throttled (total events = 1)
Jun 22 10:55:52 alien kernel: CPU1: Package temperature above threshold, cpu clock throttled (total events = 1)
Jun 22 10:55:52 alien kernel: CPU0: Package temperature above threshold, cpu clock throttled (total events = 1)
Jun 22 10:55:52 alien kernel: CPU4: Package temperature above threshold, cpu clock throttled (total events = 1)

In my case it happens so rarely and with no adverse side-effects I've chosen to ignore the errors.

Similar launchpad bug reports on the same issue:

And just so you know it's not just Ubuntu, from Redhat:

  • What thermal/fan control packages do you have installed? If thermald is one of them, have you customized /etc/thermald/thermal-conf.xml for your hardware configuration? – heynnema Jul 14 at 13:52
  • @heynnema I've never used software to control the fans. I do use thermald but it has default config file. Fans are controlled by the laptop and almost never come on. I have to do something silly like run all 8 CPUs at 100% for more about a minute. – WinEunuuchs2Unix Jul 14 at 14:23
  • See my answer for a brief intro on how to develop a custom .xml file to control thermald. It's not that difficult. You can also search AU for other thermald answers that I've provided in the past. I've got thermald keeping my temps < 140 degrees. – heynnema Jul 14 at 14:42
  • @heynnema I don't have any temperature problems since May 20 the errors only appeared once in journalctl. I like the way the Laptop's ACPI keeps the fans turned off all the time. No noise is good noise. Conky reports temp at 51 / 52 degrees as I type this now. – WinEunuuchs2Unix Jul 14 at 14:56
  • Nice. Hey, point of note... you and I used to have similar rep, but you've blown way beyond me now. How much time do you dedicate to AU help? – heynnema Jul 14 at 15:04
2

It sounds like your /etc/thermald/thermal-conf.xml file needs to be tweaked for your hardware...

I'd install thermald...

  • sudo apt-get update

  • sudo apt-get install thermald

Thermald comes with a default configuration file at /etc/thermald/thermal-conf.xml that will control most computers, but may need to be customized for some computers. See man thermal-conf.xml for some details and examples. Once one has modified the configuration file, stop thermald and restart it:

sudo service thermald restart

After installing thermald, I'd stop the thermald process, and run it manually as sudo thermald --no-daemon to watch its actions in real time. This real time info can be used to create your own customized thermal-conf.xml file. See man thermald for more information.

sudo service thermald stop
sudo thermald --no-daemon --loglevel=debug

You can search for thermald here on Ask Ubuntu to see what previous answers there are. Many of the answers come from me.

A good starter reference is at https://wiki.ubuntu.com/Kernel/PowerManagement/ThermalIssues

0

The poblemel is therefold. First you have a high cpu usage. Secondly, the CPU's cooling is not enough and third , it doesn't correctly throttle.

Higher cpu usage might be due to unity not correctly using you hardware geoduck acceleration. And unity is quite cpu intensive. You might twerk it or even switch to a different desktop manager, le cinnamon, Kubuntu, lubuntu or Linux mint.

Cpu cooling on laptops is notoriously bad. Cleaning your company fan and putting the laptop on a flat surface instead of fabric/pillow might help.

About trottling, you can set the maximum cpu frequency to a lower setting or switch to power saving mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.