3

I'm using Kubuntu. I study theology, semitic language and Bible manuscripts.

In Manjaro and Android 8.1, the font used for Phoenician look like this:

Phoenician font appearance in Manjaro & Android 8.1

But in Kubuntu, the Phoenician alphabet font are like this:

Same in Kubuntu

So, how can I change the Kubuntu Phoenician font to that used by Manjaro and Android Phoenician font? The Manjaro/Android font is easily to read (cause is the Phoenician alphabet that I learned first), and I need to use that.

3
  • I'd love to help, but in what program are the fonts an issue? Have you added to your Kubuntu system the fonts used in your Manjaro system?
    – guiverc
    Jul 13 '19 at 6:36
  • Hi Guiverc! I didn't used programs and i don't added fonts used in Manjaro OS. I want to know if i have to download it and install or if i can just change settings on Kubuntu system to show this font...
    – Neg3v
    Jul 13 '19 at 20:54
  • The picture looks more like that of an android phone which I don't know (I can barely operate my own galaxy) but getting Kubuntu to do what Manjaro does should be easy, we need to know what program, and font you are happy with in Manjaro (which is another GNU/Linux distro like Ubuntu is; manjaro.org), or when you say Manjaro do you mean something different?
    – guiverc
    Jul 13 '19 at 22:11
2

To make the desired font the default for rendering Phoenician characters, this is a way:

  1. Open a terminal window with Ctrl+Alt+T

  2. Create the directory ~/.config/fontconfig/conf.d:

    mkdir -p ~/.config/fontconfig/conf.d
    
  3. Open the Text Editor:

    kate ~/.config/fontconfig/conf.d/10-prefer-phoenician.conf
    

    and copy the below contents and paste it into the Text Editor:

    <?xml version="1.0"?>
    <!DOCTYPE fontconfig SYSTEM "fonts.dtd">
    <fontconfig>
            <alias>
                    <family>sans-serif</family>
                    <prefer>
                            <family>Noto Sans Phoenician</family>
                    </prefer>
            </alias>
    </fontconfig>
    
  4. Save the file.

That should make your system prefer Noto Sans Phoenician over other fonts you have installed which claim to be able to render Phoenician.

7
  • Sorry, i'm newbie at Linux and don't know how to execute these commands. There's another way?
    – Neg3v
    Jul 15 '19 at 3:38
  • @Neg3v: I edited the answer to be a more step by step instruction. There are probably other ways, but this is the one I know. Ask if there is something I can explain better. Jul 15 '19 at 4:35
  • Everytime i create the directory and edit in text editor (Kate, in my case), he can't save the file and don't change anything...
    – Neg3v
    Jul 15 '19 at 23:31
  • 1
    @Neg3v: It's sufficient to create the directory once. What I simply suggest is that you put a file named 10-prefer-phoenician.conf in that directory with the contents as above. Did you open kate from a terminal window as I suggested above? Jul 16 '19 at 0:14
  • Man, have you ever heard about love? That's what i'm feeling about you. That worked after a Kubuntu update in the fonts.
    – Neg3v
    Jul 16 '19 at 4:08
1

This may be what you are after, but it's likely not your only option.

enter image description here

guiverc@d960-ubu2:/usr/share/fonts$   dpkg -S /usr/share/fonts/truetype/noto
fonts-noto-ui-extra, fonts-noto-mono, fonts-noto-extra, fonts-noto-color-emoji, fonts-noto-core, fonts-noto-unhinted, fonts-noto-ui-core: /usr/share/fonts/truetype/noto

You can likely install these with sudo apt install fonts-noto

guiverc@d960-ubu2:/de2900/ubuntu_podcasts/action$   dpkg -l |grep noto
ii  fonts-noto                                    20181227-1                                  all          metapackage to pull in all Noto fonts
ii  fonts-noto-cjk                                1:20190409+repack1-0ubuntu1                 all          "No Tofu" font families with large Unicode coverage (CJK regular and bold)
ii  fonts-noto-cjk-extra                          1:20190409+repack1-0ubuntu1                 all          "No Tofu" font families with large Unicode coverage (CJK all weight)
ii  fonts-noto-color-emoji                        0~20180810-1                                all          color emoji font from Google
ii  fonts-noto-core                               20181227-1                                  all          "No Tofu" font families with large Unicode coverage (core)
ii  fonts-noto-extra                              20181227-1                                  all          "No Tofu" font families with large Unicode coverage (extra)
ii  fonts-noto-hinted                             20181227-1                                  all          obsolete metapackage to pull in a subset of Noto fonts
ii  fonts-noto-mono                               20181227-1                                  all          "No Tofu" monospaced font family with large Unicode coverage
ii  fonts-noto-ui-core                            20181227-1                                  all          "No Tofu" font families with large Unicode coverage (UI core)
ii  fonts-noto-ui-extra                           20181227-1                                  all          "No Tofu" font families with large Unicode coverage (UI extra)
ii  fonts-noto-unhinted                           20181227-1                                  all          "No Tofu" font families with large Unicode coverage (unhinted)
ii  python-monotonic                              1.5-0ubuntu1                                all          implementation of time.monotonic() - Python 2.x

This is rather untidy and may require editing. I found another biblica font first, but opted to use this as it contains the word Phoenician, and still think getting the font you are happy with in Manjaro GNU/Linux's name, and just adding that to Kubuntu is possibly the best option. This is also written as I found things..

4
  • Yeah! This is what i'm looking for! How i change the default Kubuntu phoenician font to this? I already installed using the Konsole.
    – Neg3v
    Jul 14 '19 at 2:03
  • 1
    I don't know what application you are using which is why I asked before this answer was done. If you were using libreoffice (writer) go to the 'Fonts' tab where I typed "Noto Sans P" and then selected it. I have loads of noto fonts on this machine which is why I typed so much to narrow down the list to those starting with "Noto Sans P". Different apps have different requirements (but your selecting it in LibreOffice will make it appear near the next of the drop-down-list for next time so it'll be easier to find.
    – guiverc
    Jul 14 '19 at 3:19
  • I use WPS Office. But i don't want to only write in phoenician or old hebrew. I want to see, in every text written in phoenician (like Wikipedia pages) this font. How could i do that?
    – Neg3v
    Jul 14 '19 at 4:26
  • I love you, my friend.
    – Neg3v
    Jul 16 '19 at 4:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.