0

Scenario

  • Kubuntu desktop 18.04, tower
  • Lubuntu desktop 18.04, laptop
  • Windows 10, laptop

Kubuntu

[kubuntu_home]
   path = /home/myusername
   available = yes
   valid users = myusername
   read only = no
   browseable = yes
   public = yes
   writable = yes
  • I thought that there was a typo on the website, but when I checked it out on samba.org, I found that writable is a synonym for writeable.

Lubuntu

$ sudo mount -t cifs -o username=myusername,password=mypassword //192.168.###.###/kubuntu_home /mnt/kubuntu_home

Windows

Problem

From Lubuntu, I can read files but cannot write.

  • From Kubuntu, ls -l ~ shows files and directories as belonging to myusername myusername.
  • From Lubuntu, ls -l /mnt/kubuntu_home/ displays all files and folders as belonging to root root.
  • Somewhere along the way, I saw a suggestion to add force user = myusername to smb.conf. This did not make a difference.
  • No problems reading/writing from Windows.
0

Take possession of the mounted share so that it's owned by you not root.

Change this:

$ sudo mount -t cifs -o username=myusername,password=mypassword //192.168.###.###/kubuntu_home /mnt/kubuntu_home

To this:

$ sudo mount -t cifs -o username=myusername,password=mypassword,uid=1000 //192.168.###.###/kubuntu_home /mnt/kubuntu_home

By adding uid=1000 to the list of options.

Note: Your uid number on the Lubuntu machine may not be 1000. To verify that number run id in a terminal and change the mount command if necessary.

| improve this answer | |
  • Thanks very much @Morbius1! – granti128 Jul 13 '19 at 19:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.