0

Got this error during installation of gnuradio. I also got this:

usr/share/mime/packages/gnuradio.xml:1: parser error : Start tag expected, '<' not found.

Should I be concerned? Everything else completes without errors.

  • head -n3 /usr/share/mime/packages/gnuradio.xml edit your question for the output. – nobody Jul 13 at 9:05
  • My apologies, but I fail to parse the comment. – Gordon Jul 14 at 0:13
0
sudo nano /usr/share/mime/packages/gnuradio.xml 

Go to the first row and make sure it begins with an <

sudo update-mime-database -V /usr/share/mime/

This updates the mime database.

0
  1. Delete /usr/share/mime/packages/gnuradio.xml.
  2. Symlink gnuradio-grc.xml to gnuradio.xml:

    sudo ln -s gnuradio-grc.xml gnuradio.xml
    
  • Hello and welcome to AskUbuntu. Please provide some explanation, why the deleting and symlink creation is needed. – Simon Sudler Oct 14 at 8:57
  • /usr/share/mime/packages/gnuradio.xml contains a single line "/usr/share/mime/packages/gnuradio-grc.xml". Sorry for my bad English. – Eko Kurniawan Oct 15 at 9:28
  • Installation process failed to create a symlink. – Eko Kurniawan Oct 15 at 18:32
  • Please "edit" your answer and add the explanation – Simon Sudler Oct 16 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.