-1

I notice some posts in which a nvidia VGA controller exists, which is not my case

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
04:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 940M] (rev a2)

I have the version 430 of nvidia drivers. Don't they have VGA controller support? Playing videos seems slow refreshing with an "horizontal line" kind of freezing lag (EDIT: screen tearing). Is intel controlling vga and nvidia 3D despite nvidia being prime selected?.

  • 2
    No, only one card works at a time. The energy saving profile activates the Intel iGPU and the high performance profile the Nvidia. – GabrielaGarcia Jul 12 at 15:47
  • interesting. maybe the solution is: echo performance | sudo tee /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor – Ferroao Jul 12 at 16:00
  • 2
    I don't think so. What you have is screen tearing and that can happen for a number of reasons and with different graphics and drivers and also varies a lot between desktop environments. Recently I had to correct a similar situation with an Intel and Ubuntu-MATE. The some PC with standard Gnome had no issues. – GabrielaGarcia Jul 12 at 16:04
  • 2
    You use sudo prime-select nvidia and reboot to go to the NVIDIA card. sudo prime-select intel to go to the Intel card. And prime-select query to show what it is presently set to. Also, @GabrielaGarcia is correct in the screen tearing happens for many number of reasons. For mine it was the drivers, but also that I needed to use Compton instead of the xfwm for my Xubuntu installation. – Terrance Jul 12 at 16:21
0

Well, thanks for the comments. I followed the steps in http://ubuntuhandbook.org/index.php/2018/07/fix-screen-tearing-ubuntu-18-04-optimus-laptops/ to solve screen tearing

Reposted from: https://ubuntuforums.org/showthread.php?t=2374405

Despite some initial VLC stall, Screen tearing was reduced from common video. In some special cases, see: https://www.youtube.com/watch?v=9hIRq5HTh5s it seems to persist.

Steps:

1. Create file
sudo gedit /etc/modprobe.d/nvidia-drm-nomodeset.conf
2. Add content:
options nvidia-drm modeset=1
3. Update
sudo update-initramfs -u
4. reboot
5. Check (Y)
sudo cat /sys/module/nvidia_drm/parameters/modeset

Optional: (see link)
-Set maximum performance in Nvidia Settings -> PowerMizer.
-if you have MORE than enough RAM, set swap tendency to a MUCH lower value editing sysctl.conf

cat /proc/sys/vm/swappiness
sudo gedit /etc/sysctl.conf
#add
vm.swappiness=15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.