2

I quick installed ubuntu on windows 10 hyper-v, it has a default virtual network adapter along with the virtual switch but it doesn't want to connect to the internet.

1
  • I am having the same issue with Hyper-V and Ubuntu 19.04. Were you able to solve it? – kerzek Aug 31 '19 at 2:03
1

I know this is old but deserves an answer.

  • Go to network adapters and settings
  • Right click the adapter that is giving you internet
  • Click properties
  • Click the tab Sharing
  • Check the box allow other network users to connect through this computers internet connection

Doing this will also give your machine a 192.168 address instead of a 172.17

I am assuming, by default, it will not let you connect to the outside world, unless you choose external. I usually create an internal adapter, apply these settings, give it the IP address range I want through powershell. Then give the vm a static IP address.

Hopefully this helps someone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.