I had Ubuntu 16 then upgraded to 18 then installed KDE. Now I have slow main menu appearance. It takes 1-2 second and unrelated with animation.

I saw suggestions to remove xorg.conf, but didn't find one.

All other popups are also enslowed.

  • Could you record a screencast with e.g. gtk-recordmydesktop to demonstrate the effect? – Nathaniel M. Beaver Jul 15 '19 at 16:05

You mention that you started with Ubuntu 16 and upgraded to Ubuntu 18; from the tag I infer you mean 18.04 (BionicBeaver) from either 16.04 or 16.10. Have you read the release notes or change summary for Ubuntu / Kubuntu 18.04? Many of them are relevant to blacklisting drivers for particular hardware, including graphics.

Depending on how you made the upgrade, you may have leftover configuration files that are incompatible with the newer software or simply lack bug fixes and workarounds.

For example, if the files in /usr/share/X11/xorg.conf.d/ and /etc/modprobe.d/ are from Ubuntu 16.04 but the kernel and drivers are for Ubuntu 18.04, this could potentially cause a performance issue, although I don't know enough about your hardware to look for any known bugs. On my machine, /usr/share/X11/xorg.conf.d/10-quirks.conf alone provides workarounds for four separate input device bugs.

Deciding which configuration files to keep the same and which to upgrade to a newer version can be a delicate process, so some folks just prefer to re-install from scratch to ensure they are using the recommended configuration from their distribution. This is the method that I personally find to be the most expedient; I re-install onto a new disk and then copy my data over. After that, I mainly migrate configuration for my home directory and leave global configuration largely the same, except for things like wifi connections and printers.

This brings up the consideration of configuration files in your home directory, such as ~/.config/kdeglobals. The package manager generally leaves these files alone, so to isolate the bug you may have to start with the default Plasma 5 configuration and bring in your customizations piece by piece. (You can also use a binary search strategy, adding half your configuration settings at a time and backing up if the half you added re-introduces the bug.)

For example, the configuration for many plasma applets is stored here:


How an older configuration file will affect performance depends on a variety of factors, such as which application launcher you are using. For example, are you using Application Menu (kicker), Application Dashboard (kickerdash, the full screen launcher), or Application Launcher (kickoff)? You can switch between them with right-click → "Alternatives...". Are they all equally enslowed? Does this change if you alter the settings?

You can try toggling settings like useExtraRunners ("Expand search to bookmarks, files and emails"). You can change this via right-click → "Application Menu Settings..." or "Application Launcher Settings...". Here's what it looks like for Application Launcher (kickoff):

Application Launcher Settings -- Plasma

By the way, how do you actually know it is unrelated to animation?

Have you tried disabling animations?

Have you tried disabling compositing?

Have you recorded a screencast demonstrating the problem with e.g. gtk-recordmydesktop?

It would be helpful to have a screenshot of your "About System" screen, like this:

About System -- System Settings Module

This would provide information about the exact version you are using (useful for other folks who read this question) and some basic hardware information.

I also use KDE on Ubuntu 18.04, but I don't experience anything like what you're describing. Without more information, I can only speculate as to the cause of the delays you are experiencing.

If you want to dig deeper, the source code for the kicker and kickoff plugins is in the plasma-desktop package. For example, here is the code to generate the action list for kicker:


and here's the QML code for part of kickoff:


  • All plugins are enslowed equally. I compared speed with another computer. Once you click, several seconds passed, and just then animation is starting. So removing animation won't affect the situation. Removing extra runners didn't help. This question is a matter of bug, not a matter of config. – Dims Jul 16 '19 at 7:11
  • @Dims I understand this is an annoying problem, but I also use KDE on Ubuntu 18.04, and I do not observe a 1-2 second delay when I open the Application Launcher; for me it is very fast. So it is a matter of difference in configuration, hardware, software version, or software dependencies. Could you provide more information about these things? Or a screencast to demonstrate? – Nathaniel M. Beaver Jul 16 '19 at 12:24

Things to try;

Create another user and see if it works there, then migrate your files from previous user.

Try a different desktop manager. I used to use kde, and now use lxqt, which is very lightweight.

Check cpu and memory usage. Maybe something odd stands out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.