0

I've been trying to print with my lab's network CP4025 printer but I can't make it work properly.

Using Atril document viewer, I can print something but with very simple configurations (no recto-verso for example) and sometimes it messes up the font, so I usually rasterize the whole pdf file before printing it just to be safe.

Using other file viewers (like Okular, my viewer of choice) I can't even find the printer without installing the drivers, which doesn't surprise me.

The problem is that I installed hp-lib and cups and managed to make them automatically find the network printer and set it up, but every time I send I job, the printer does nothing (even from CUPS' or hp-lip's test print utility).

Does anyone know how to debug this?

PS.: I tried both with CUPS and with hp-lip separately, same results.

  • Are you sure about exact printer model? I do not see any CP4025 on HPLIP page, but cp4020 is supported by HPLIP 3.9.12. So you need to install hplip-gui package from repository and test it again. – N0rbert Jul 18 at 9:54
  • Yes I am sure, I suspect there's still no way for me to access this particular printer, sadly. – ebernardes Jul 19 at 6:54
  • I have the same printer in my office. Did you solve your problem? – becko Sep 9 at 14:34
  • I searched a bit and apparently, it's a new printer that isn't yet supported on Linux, sadly. Here's what I do: For some reason, Atril Document Viewer (a simple pdf viewer that came with Xubuntu by default) can send documents to the printer even without any configuration, but sometimes it screws up some characters. So I usually rasterize the document I want to send with some other software and print it with Atril. Practical? No, time consuming and I can't make it print on both pages. But at least it works. Tell me if it works for you (or if you find some other solution)! – ebernardes Sep 10 at 9:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.