4

Following this post I tried this command:

sudo update-alternatives --config x-terminal-emulator

But it doesn't list the deepin-terminal:

There are 2 choices for the alternative x-terminal-emulator (providing /usr/bin/
x-terminal-emulator).

  Selection    Path                             Priority   Status
------------------------------------------------------------
  0            /usr/bin/terminator               50        auto mode
* 1            /usr/bin/gnome-terminal.wrapper   40        manual mode
  2            /usr/bin/terminator               50        manual mode

Press <enter> to keep the current choice[*], or type selection number

I have also tried from this other question, these two commands:

sudo apt install --reinstall deepin-terminal
sudo dpkg-reconfigure deepin-terminal

None worked, do you have any other ideas? Thanks in advance.

6

For me, the following worked

https://github.com/linuxdeepin/deepin-terminal/issues/186#issuecomment-517919007

# Register deepin terminal
sudo update-alternatives --install /usr/bin/x-terminal-emulator x-terminal-emulator /usr/bin/deepin-terminal 50

# Select your terminal
sudo update-alternatives --config x-terminal-emulator

No reboot needed.

2
  • 1
    This worked for me on Ubuntu 20.04 TLS running Gnome 3.36.1 – Frank Fu Apr 24 '20 at 14:45
  • 1
    This worked for me! Thanks. – Daniel Jun 29 at 4:22
1

the only solution that I found was this:

sudo gsettings set org.gnome.desktop.default-applications.terminal exec /usr/bin/deepin-terminal
sudo gsettings set org.gnome.desktop.default-applications.terminal exec-arg "-x"

And It works for me.

1
  • Thank you. I also had to logout and login for it to kick into effect. – Frank Fu Oct 11 '19 at 12:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.