1

I was trying to install a Bioinformatics related software i.e Multigeneblast. I have downloaded and untar the tar.gz file in the /home/hiya(in home directory). Now according to the documentation of the tool to run the software we only need to run the command mgb_gui or multigeneblast. But when I have tried it that's giving some font error.(screenshot included). Then I have tried to install Fontconfig-2.13.1 package.I followed every step like untarring the tar.bz2 and then following commands

rm -f src/fcobjshash.h ./configure --prefix=/usr        \
            --sysconfdir=/etc    \
            --localstatedir=/var \
            --disable-docs       \
            --docdir=/usr/share/doc/fontconfig-2.13.1 && make

then its giving a configure error.(ScreenShot2) And after giving make install command its showing

make: *** No rule to make target 'install'.  Stop.

what Should I do to solve it.Please let me know.Configur_ErrorMultigeneblast Error

  • Please don't post screenshots of terminal output. It's preferable to copy/paste the relevant text. See meta.askubuntu.com/questions/8713/… – DK Bose Jul 11 at 8:48
  • Thanks for your suggestion. It is quite right up to some extent. but in some of the case we need to put that. I have just posted the relevant part. – HIYA SINGH Jul 11 at 8:56
  • Hello and welcome to askubuntu. Fontconfig-2.13.1 is included in the standard repositories of Ubuntu. There is no reason to compile it manually. Also, if I am not mistaken, your error message does not imply that fontconfig is not installed. – Bruni Jul 11 at 8:56
  • 1
    Why are you deleting those files? What is the first command supposed to do? rm -f src/fcobjshash.h ./configure --prefix=... will delete the files src/fcobjshash.h and ./configure. Is this what you actually ran or did you maybe run rm -f src/fcobjshash.h; ./configure ...? – terdon Jul 11 at 9:24
  • 1
    Yes, as I thought. The instructions tell you to run rm -f src/fcobjshash.h first and then run ./configure --prefix=. You are running them together so you deleted the ./configure script. – terdon Jul 11 at 9:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.