1

I have applications that require the JDK-12 of Java. I used to run my applications in the OpenJDK Java 8 Runtime (those were SWIFT applications, so all I had to do, was double click on them). But now, I have to install the new JDK in order to run this application. But, they automatically open with Archive Manager.

I'm pretty sure that I installed JDK 12 and later tried out JAVA alone. I tried using the old OpenJDK 8 but of course it cannot open my applications for Java 12.

How can I run my applications in the new Ubuntu 18 with JDK-12?

0

The simplest way to check if JAVA is installed and what version of JAVA you're using:

update-java-alternatives -l shows you all the Java versions you have installed.

java -version shows you the Java version you are using.

java -showversion shows you the Java version you are using and help.

However, it seems like you probably don't have JAVA(JDK 12) installed, that's why the .jar file is opening with Archive Manager. Still, try right clicking on the .jar file and select the Java Runtime Enivornment to run the file.

  • Yes, i do have Java installed and of course that commands show me the version that i have. I guess i will recompile all the applications to Java 8 – Ameno Jul 11 at 10:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.