I have a MSI GF63 laptop (with core i5 and Nvidia GTX 1650) and I'm currently trying to dual-boot ubuntu alongside windows. This laptop is a 2019 edition (bios firmware fully updated) and comes with UEFI and the GPT partition table. These are the methods I've tried so far (with no success)

1. Live USB 1

Config: Partition Scheme- MBR, Target Device- BIOS or UEFI

Live USB shows up when BIOS is set to Legacy only (not even on UEFI with CSM). After that I proceeded with the installation (by creating the required partitions for swap, root and /home) but I could not boot ubuntu after installation completes. The system boots directly into Windows and not even lets me choose the OS. A quick google search told me that I need to install ubuntu in UEFI mode and not Legacy (since my defice is a UEFI one). And as I'm not well versed with these things (read casual user or n00b perhaps) so I can't figure out what that means.

2. Live USB 2

Config: Partition Scheme- GPT, Target Device-UEFI

Expected the Live USB to show up on the boot menu (accessed after pressing f11 on my system), but it didn't. At first I thought there was an issue while creating the Live USB, so i formatted the USB and created it again (using rufus) but it still didn't show up


Nothinhg I do seem to work for me. I've tried the above methods once while turning off fastboot and Secure Boot and other time with Secure Boot on and fastboot off, but nothing seems to happen. My Live USB boots fine in Legacy mode and has no graphics driver problem (and while in Ubuntu, the default graphics is handled by the CPU and not the GPU, so there are no apparent problems with Nvidia Graphics drivers).


As windows came preloaded, I don't have an installation media and so don't want to uninstall everything and install ubuntu from scratch. I want to install ubuntu alongside the current Windows 10 without disturbing it.

Edit: Here's some of my default BIOS configs (if it helps) img1 Img2 IMG3

  • What are the options under USB configuration? Ubuntu should be installed in UEFI mode, as that's how Windows is installed. Secure Boot and Fast Boot disabled. Some F12 boot menus have a limited number of available slots to display, so make sure that no other USB devices are plugged in. Try and create a new USB flash using Startup Disk Creator in Ubuntu Live. – heynnema Jul 10 at 16:09
  • 2
    Some also have settings on USB to allow full support or allow boot. And then in UEFI one time boot should be two boot entries for USB flash drive, one BIOS and one UEFI:xxxxx where xxxxx is name or label of flash drive. My Asus motherboard says PMAP or UEFI:PMAP. Ubuntu installer will boot if Secure Boot is on, but USB boot allowed, but then no BIOS boot. USB boot usually not considered Secure. UEFI only USB key, just extract ISO (7 zip or similar) to FAT32 formatted flash drive partition & set boot flag. askubuntu.com/questions/395879/… – oldfred Jul 10 at 16:18
  • 1
    See also: MSI GE63 Update UEFI then acpi=off not required askubuntu.com/questions/1059029/18-04lts-msi-ge63-boot-issues & askubuntu.com/questions/1038637/… – oldfred Jul 10 at 16:28
  • 1
    When I need a Live or Persistent USB that boots both BIOS and UEFI I use mkusb to make the drive: help.ubuntu.com/community/mkusb – C.S.Cameron Jul 10 at 16:36
  • 1
    The acpi=off is a boot parameter that you add to grub menu. If it starts to boot, you may need to press escape key after UEFI screen, but before grub to get grub menu. Another possible similar mode. Issues are often common across many models as UEFI is same or very similar with just minor changes for options: Bigger difference if Intel or AMD in same brand: askubuntu.com/questions/1061109/… – oldfred Jul 10 at 16:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.