0

just installed a fresh Ubuntu 18.04 on my HP laptop last Monday (and upgraded it to latest 18.04.02). My 4K LG monitor worked as expected, yesterday I worked with another external HD monitor without issue. Returning to my original setup however I cannot get the laptop to detect my external monitor (obviously I checked cables etc. and ruled them out). xrandr shows: HDMI-1 disconnected (normal left inverted right x axis y axis) lspci: 00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 620 (rev 07)

I checked the logs and found the following 'important' messages (which I'm not sure are related): Cannot access vdagent virtio channel /dev/virtio-ports/com.redhat.spice.0 [pulseaudio] backend-ofono.c: Failed to register as a handsfree audio agent with ofono: org.freedesktop.DBus.Error.ServiceUnknown: The name org.ofono was not provided by any .service files

restarted vdagent daemon manually and it seems to be running without issue.

I'm running the following kernel: 4.18.0-25-generic #26~18.04.1-Ubuntu SMP Thu Jun 27 07:28:31 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

~/.monitors.xml contains both the configurations, wonder if that matters since xrandr doesn't even show HDMI-1 as connected.

I tried to fiddle with xrandr manually to no success: e.g. xrandr --output HDMI-1 --auto

Appreciate any help to resolve this issue.

regards, Aias

  • Interestingly, I reset my UEFI (BIOS) to factory defaults; rebooted and now it works again?? – Aias Jul 10 at 16:33
  • only setting I can find in the BIOS that relates to the videocard is a memory setting. It could be that I had increased it previously, right now its set to 32MB. – Aias Jul 10 at 16:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.