0

I'm running Ubuntu 18.04 in a VirtualBox on a Windows 10 machine.

I'm trying to create and test a Docker swarm by creating a couple virtual machines on my (virtual) Ubuntu OS. (I know, I know. VMs on VMs on VMs. I should just get a Mac). I've downloaded VirtualBox in Ubuntu, and am running the following at command-line:

docker-machine create --driver virtualbox myvm1

Which returns:

Running pre-create checks... Error with pre-create check: "This computer doesn't have VT-X/AMD-v enabled. Enabling it in the BIOS is mandatory"

Virtualization is enabled on my Windows 10 machine:

Task Manager Performance Sccreenshot

Virtualization also appears enabled for Ubuntu, as viewed through the VirtualBox Settings (running on Windows):

Ubuntu Virtualization Settings

I've tried to enable through the Ubuntu BIOS on startup, but I can't seem to get in there to change anything. If I press F2 or F12 or ESC (or any key for that matter), I can see a list of processes running during startup, but don't have any control, and the OS just boots as normal. Ancillary question, is there a BIOS for Ubuntu running on a VM, or just one for my hardware?

I read that perhaps I should disable Fast Startup on my Windows machine, and have done that, but have seen no difference. And my host machine boots up pretty fast anyway, too.

UPDATE:

If I run in Ubuntu Terminal,

grep --color vmx /proc/cpuinfo

nothing is returned. Same for svm, which would appear to confirm that virtualization is not enabled or possible. The ultimate question is, how do I enable it?

  • Read the error message carefully: You need to boot into BIOS and simply enable that BIOS setting. On your hardware running your Win 10 host. – user535733 Jul 10 at 13:29
  • thanks @ user535733. If i'm running a virtual machine on my Win 10 host, doesn't that indicate I have virtualization enabled? See above update. – tim.farkas Jul 13 at 14:18
  • No: Hardware virtualization is a performance feature, not a security feature. You can run virtualization in software without enabling any hardware features...it's merely much less efficient to do so. – user535733 Jul 14 at 1:28
0

If you want virtualisation INSIDE the guest then you need to enable that in the virtualbox settings.

See https://docs.oracle.com/cd/E97728_01/F12469/html/nested-virt.html

enter image description here

If you wanted something else then perhaps you can clarify your question?

0

My setup is similar yours and I encountered the same error. The following code fixed the issue for me.

docker-machine create --driver virtualbox --virtualbox-no-vtx-check myvm1

Here's a link where I found it. https://docs.docker.com/machine/drivers/virtualbox/

I hope it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.