0

I am in the middle of trying to resolve the dreaded Radeon issue with the 2011 Macbook pro. I have created a bootable USB stick with everything I should need to eventually disable the Radeon GPU ahead of removing a sensor to complete the job. I am using the ubuntu-16.04.3-desktop-amd64.iso

There a couple of modifications to the created stick, with a new grub.cfg file to replace the existing one and the addition of a Radeondisable.sh file in the root of the stick to disable the GPU

When I boot into the stick, I select Try Ubuntu Without Installing, but it sits at a black screen and does nothing. Mine doesn't look exactly like images I have seen, with a * appearing before the words Try Ubuntu......

Any help gladly accepted

By the way, I have already seen to type e after selecting Try Ubuntu...... but nothing happens when I do that; no possibly to edit at that point

5
  • Have you tried rEFInd? I got better results booting both Ubuntu and OS X from rEFInd than using GRUB on my old MacBook (Late 2007). @tatsu Still installing Ubuntu on a MacBook is on-topic here.
    – Melebius
    Jul 10 '19 at 10:00
  • I do appreciate your reply, @tatsu, truly I do, but the Radeon issue I spoke of with 2011 Macbooks IS dreaded and certainly only underground due to Apple's disgraceful behaviour at the time and YES, Ubuntu is required for the fix, thus why I was here rather than ther Mac support. The idea is to use Ubuntu to disable the Radeon GPU with an .sh file using the modified boot image and then to physically have a small sensor removed to finalise the job. Here is the site I have been following and have been working through it step by step realmacmods.com/macbook-2011-radeon-gpu-disable
    – honkin
    Jul 11 '19 at 10:26
  • 1
    In the end, I was able to get Ubuntu working yesterday. My mistake as I was trying to type the e after hitting enter. I mistook the term select and instead hit enter. When I simply typed e with the Try Ubuntu... selected, I was able to modify the boot and get into Ubunto, do the mod and have since had the sensor removed and the patient is doing well. Thanks for the replies
    – honkin
    Jul 11 '19 at 10:26
  • @honkin I'm glad you solved this issue. I hope I didn't come off as rude. :)
    – tatsu
    Jul 11 '19 at 11:31
  • @honkin Thanks for your feedback. Consider posting the information from your latest comment in an answer below. See also askubuntu.com/help/self-answer, How to Answer
    – Melebius
    Jul 15 '19 at 7:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.